NoMachine random time-outs

Forum / NoMachine for Windows / NoMachine random time-outs

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14755

    I’ve been using NoMachine on my dedi, and I’ll be connected just fine. Then, out of nowhere, it will just stop letting me connect. I can ping the machine and I get a reply, but NoMachine just stops working and I have to get the datacenter to do a manual reboot every single time.

    An example, I was using it today just fine, I disconnected by closing NoMachine and tried to connect a few hours later and it just wouldn’t let me anymore. This happens regularly.

    Any help would be fantastic, thank you.


    Home PC using Windows 10

    Server PC using Windows Server

    ERROR: 138: Connection timed out


    There is not enough information to be able to provide any guidance. It would be better to see the logs from both machines.

    Please see the following article for instructions on how to enable them, reproduce the error, and then extract them. Also confirm what version of NoMachine you have installed on both your Windows hosts.


    You may want to try checking the “port” listed for the remote

    I had the same error and it turned out that the port # (because?) had changed and when I changed the port assignment in the connection on the client it worked

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.