NoMachine refuses to re-attach to physical session

Forum / NoMachine for Linux / NoMachine refuses to re-attach to physical session

Viewing 8 posts - 16 through 23 (of 23 total)
  • Author
    Posts
  • #18999
    fermulator
    Participant

    Finally able to retest today.

    Yesterday was physically on site, performed various OS updates, rebooted, and confirmed that there is a physical session initiated from the physical keyboard. (used the system all day)

    Today attempted to remote, and the UI connects, however:

    1. never gives me the option to “create a display”

    2. never shows that there is an “existing display” to connect to

    Let it sit there for a few minutes, nothing. Checked the server logs and it was spewing all sorts of stuff in a loop. (sending logs via e-mail)

    #19008
    Britgirl
    Participant

    Logs received ūüôā

    #19113
    brotech
    Participant

    Hello fermulator,

    Sorry for the delay in replying, I thought we had already replied with the workaround.

    The problem you experience might be related to your recent OS updates, in particular to krb5-workstation package.

    We suspect that it’s:

    https://www.nomachine.com/TR07P08710

    The problem was solved in our test environment by downgrading krb5-workstation
    package from:

    Version     : 1.15.2
    Release     : 9.fc27

    to:

    Version     : 1.15.2
    Release     : 2.fc27

    #19129
    fermulator
    Participant

    Indeed, my system has a newer version of this.

    $ rpm -qa | grep krb5-workstation
    krb5-workstation-1.15.2-9.fc27.x86_64

    Come to think of it, it’s possible that it aligns with the system upgrade from Fedora26 -> Fedora27 (I think I noticed the problem much later post-upgrade, so the correlation did not come to mind).

    That problem report linked seems quite light-weight. Is NoMachine planning to update it with more information + workaround + ETA for resolution?

    #19147
    Cato
    Participant

    Hello fermulator,

    The solution for the problem will be part of next NoMachine official release, which should come out in the next two-three months. Our advice to users experiencing the issue is to downgrade krb5-workstation packages for now.

    #19406
    fermulator
    Participant

    Status doesn’t really make sense.

    I was already running 6.0.X version, and the KB says:

    https://www.nomachine.com/TR07P08710

    TR07P08710
    Added on: 2018-07-11
    Last update: 2018-08-23
    Affects: 6.0
    Due to be solved in: 6.0

    What target release is it going to be fixed it?

    It says last updated today, but I do not see any differences.

    #19411
    Britgirl
    Participant

    @fermulator, a modification can occur for any number of reasons – from a typo to the closure/implementation. This is the general rule of our KB entries (articles, docs, FR and TR). It’s an indication of freshness.

    In the case of this TR, its internal status has changed, for the developers. Showing the modified date could be misleading in the case where there is no visible change to the customer. I’ll bring it up with the web team and see what improvements can be made.

    As for the release date, Cato gave an indication in his last reply just above.

    #20079
    Britgirl
    Participant

    Make sure you update to the latest 6.3.6 as it includes the patch for TR07P08710.

Viewing 8 posts - 16 through 23 (of 23 total)

This topic was marked as solved, you can't post.