NoMachine server will not run after re-install

Forum / NoMachine Terminal Server Products / NoMachine server will not run after re-install

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #27019

    I installed NoMachine Terminal Server on my Ubuntu 18 server and it worked for a while.
    After having issues with it , I uninstalled NoMachine, and attempted to re-install according to published instructions.
    Now server is not running and i am not able to track down the issue(s).

    I have included logs in hopes you can point me in the right direction.



    Looks like you don’t have enough disk space. What you need to do is have a clean of your server and make some space on your server host.

    System requirements necessary for NoMachine software products are provided on the download pages of each product, so for example, Terminal Server,, and also in the relative Installation Guide, “Prequisites” section. For TS we indicate general guidelines of 1 GB RAM and 195 MB free disk space.

    NoMachine software is installed by default in /usr/NX so you must guarantee that the partition where you have installed it has the amount of space that we indicate. If you can’t clear up space on that partition for whatever reason, you can install it in a different location (/opt/NX) on a different partition, see the Installation and Configuration Guide paragraph 3 for further details about that Simply make sure that the new location on the alternative partition has enough space.


    Thanks BritGirl!

    It turned out my VM snapshots were filling up the OS drive and causing the issues you pinpointed above.
    I have not tried re-installing NoMachine yet but plan to.
    Thanks Mucho!



Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.