NoMachine Service failing on Windows 64

Forum / NoMachine for Windows / NoMachine Service failing on Windows 64

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #7923


    I am trying to startup a NXserver on my Windows 7 x64 machine. This machine is on a Domain and has a local admin. I have installed the NoMachine service but:

    1- It shows no tray icom ven with the option turned on

    2 – connections to the machine using IP adress are refused – Error is 111: Connection is refused.

    3- Service is not broadcast on network. NoMachine clients cannot see the server availability.

    Logs are attached of special interest is the NXerror log, where apparently there is a SID error…



    Hi jgaalmeida,

    Logs failed to attach, for security reasons. Could you send them (server and client side) to forum[at]nomachine[dot]com, making sure to reference ‘NoMachine Service failing on Windows 64′ as subject?

    If needed, you can find instructions to gather the logs here:

    Installation logs would also be useful. In general in Windows 7 they are under <users_home>/AppData/Local/Temp and are the files starting with ‘Setup Log’. Please send the latest of these files.





    Sorry for the delay.


    Please check whether your connection to Active Directory server is active when you experience this problem. Remember that NoMachine installations requires OS reboot on Windows. (you did reboot, didn’t you?)


    Yes, I did reboot, way too many times…

    My machine is not connected to an active directory most of the time, and was never connected when I experience this problem. Please note that I have never been able to connect to the laptop using NoMachine.

    My own browsing of the logs seems to map the issue to a NoMachine inability to find my ID on the laptop. My profile is on a  disk different than C (F in my laptop) could that be the issue?






    Hello jgaalmeida,

    NoMachine curently doesn’t support domain users log-in when there’s no active connection to domain controller. We’re currently working on enabling log-in based on local domain cache. You wrote that you’ve never been able to establish connection to your host using NoMachine, I assume that you tried when connection to Active Directory server was established too.

    I recommend that you upgrade your NoMachine installation to the latest version. This might not fix your issue, but we will make sure that other already solved problems are gone. Next reproduce the problem when connected to domain controller, check also if similar problem occurs when local account is in use. After all send us new set of logs.

    Replying to your question, location of user’s profile has no influence on obtaining user’s Security Identifier, access to DC is what matters.

    • This reply was modified 8 years, 6 months ago by Cato.


    Many thanks for your detailed answer, I appreciate the time and effort to prepare it.

    Got it I will try the new version and wait for the fix to use the AD cache.

    Best Regards,


Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.