NoMachine suspends instead of running in background

Forum / NoMachine for Linux / NoMachine suspends instead of running in background

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #8926

    I’m running NoMachine to login in a linux host. When I disconnect, NoMachine stops all work, and then resumes it as soon as I login. This is not the behavior I want…I prefer NoMachine runs in the background so that processes work overnight etc.

    I actually had the behavior I wanted working before, but now it is behaving in this “suspend” way, versus the “background” way. Does anyone have any advice on how to get it to run using the “background” way?


    Hello charleshenry,
    NoMachine is not suspending the session when user disconnects.
    Could clarify you experience? Which Linux distribution are you using?
    Which version of NoMachine are you using?
    Are you accessing the physical desktop or creating the virtual session?


    I’m using the following Linux distribution: Amazon Linux Bare Metal. Kernal Linux 3.2.45-0.6.acc.624.45.283.amzn1acc.x86_64.

    Some people around are using NX machine like me but do not have the same suspension problem.

    I’m creating a session using NX machine. I set up a connection using the NX connection wizard. I do not know what “physical desktop” or “creating the virtual session” means.


    I’m been trying to fix this by reinstalling NX client on my client machine. This strategy might work because other people don’t have this problem but use similar laptops. How do I remove all traces of NX client? When I uninstall and reinstall, it looks like alot of my settings still exist.


    Hello charleshenry,
    Are using the newest NoMachine 5.0.47 (free)?
    In this case NoMachine should provide access to current working X server.
    Or ask to create X11 display when no X servers are running on this host.

    Could you provide output of command:
    ps -Af | grep X
    to confirm what is the current situation?

    nxplayer by default is keeping all setting in .nx directory in home directory.
    You could remove it to make sure that all setting are restored to default.
    Note that path to nxplayer setting directory can be changed in ‘setting’ in nxplayer menu.


    This is what the command gives me.

    username 15878  15877  5 20:15 pts/0    00:00:00 /apollo/env/envImprovement/var/bin/zsh -569XZilm
    username 15898  15878  0 20:15 pts/0    00:00:00 grep --color=auto X
    nx       102206      1  0 Nov17 ?        00:00:00 /usr/NX/bin/nxssh -nxservermode -l hchuan localhost -p 22 -x -2 -i /usr/NX/etc/keys/node.localhost.id_dsa -o PubkeyAuthentication yes -o RSAAuthentication yes -o RhostsAuthentication no -o PasswordAuthentication no -o RhostsRSAAuthentication no -o StrictHostKeyChecking no /usr/NX/bin/nxnode
    username 102210 102209  0 Nov17 ?        00:00:01 /usr/NX/bin/nxnode
    username 102238 102210  0 Nov17 ?        00:04:58 /usr/NX/bin/nxagent -D -options /home/username/.nx/<CENSORED>.com-1037-46B47A4808FFFXX33314BF4C8C78E/options -name NX - username@<CENSORED>.com:1037 - C2 :1037
    nx       102240      1  0 Nov17 ?        00:00:02 nxserver -c /usr/NX/bin/nxserver --login
    username 102260 102210  0 Nov17 ?        00:00:28 /usr/NX/bin/nxnode

    Other people around me are reporting the same problem, so it looks like a server side issue, reinstalling the client does not fix it.
    How do I determine my NoMachine version?


    It seems you are using the legacy server version. Questions about version 3.5.0 (or earlier) are dealt with via the traditional support channels. If you don’t have a subscription and you are using the free NX Free Edition or an evaluation, please contact the team via the Contact Us link in the footer of the website and select General Enquiries.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as closed, you can't post.