NoMachine with Tailscale

Forum / General Discussions / NoMachine with Tailscale

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46730
    ticotexas
    Participant

    I just found I can get around [my provider’s] CGNAT for my rural hotspot by using Tailscale. However, it’s not working with getting me remote access via NoMachine server running on Ubuntu 20.04. I’ve tried NX on port 4000 and SSH on port 22. I’ve enabled SSH in Tailscale. I’m not sure if it’s an issue with NoMachine or Tailscale. Does anyone have any suggestions?

    #46753
    Britgirl
    Participant

    We’ve checked that NoMachine works with this particular software out-of-the-box. Make sure that the TS is running on both your devices (see this other topic for brief steps https://forum.nomachine.com/topic/after-restart-can-no-longer-connect#post-46487).

    One thing to bear in mind, SSH connections are not possible if you are using the free NoMachine product. For SSH connections, you could try, for example, Enterprise Desktop, it’s available to download and provides 30 days evaluation.

    Can you submit a screenshot of what you see when you try to connect with NoMachine when TS is enabled?

    #46755
    Britgirl
    Participant

    Update: user communicated separately that the problem was fixed. TS was not running on both devices.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.