NoMachine Workstation: excessive size of logs

Forum / NoMachine for Linux / NoMachine Workstation: excessive size of logs

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #16258
    ggt-pcs
    Participant

    Today I found my server (Red Hat Enterprise Linux 7.4) with 20kb left on the root partition.  Root cause was an /usr/NX/var/log/nxserver.log with 45GB in size.

    The following messages were logged over and over again:

     

    2017-10-30 04:57:03 554.934 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28760 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.111 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.201 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28759 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.384 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.479 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28758 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.663 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.752 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28757 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 555.928 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.019 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28756 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.196 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.290 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28755 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.472 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.563 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28754 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.748 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 556.838 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28753 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 557.016 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 557.105 17551 NXSERVER NXOpen FD#0 – file /run/systemd/sessions/28752 with mode 0 and permissions 0 from PhysicSessions::__setSessionDataFromSystemd.

    2017-10-30 04:57:03 557.288 17551 NXSERVER NXClose FD#0 from PhysicSessions::__setSessionDataFromSystemd.

     

    Any idea what could have gone wrong?

    I’m using¬† “nomachine-workstation-5.3.9-8.x86_64”

    #16276
    Mth
    Contributor

    Hello.

    There is nothing wrong with this logs itself, as they are part of the search for physical session. The problem here is probably the amount of sessions registered in systemd – which IDs are reaching 28760 here. Systemd has information there stored for every open session that goes through pam (physical desktop sessions, ssh sessions, nx sessions also). So as long as it is proper, this behavior is also proper. If the number of sessions is wrong, it may be indication of systemd problems, so please check if the number is right, as this information should be cleaned when the session closes.

    For this log size I can propose two solutions.

    First, you can disable offending function. If you do not need access to physical desktop on that machine, you can edit the “AvailableSessionTypes” key in server.cfg and remove “physical-desktop” item.

    Second, you can pass server logs to syslog by uncommenting and enabling “EnableSyslogSupport” key in server.cfg:

    EnableSyslogSupport 1

    and then enable autorotate in /etc/syslog.conf as you see fit.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.