Not able to do public key authentication

Forum / NoMachine for Mac / Not able to do public key authentication

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #38905

    Hi all together,

    I am trying to authenticate by using some private rsa key. It works perfectly if i do it in the Mac OS terminal and on any Linux system. Also with GUI tools like [removed] for instance. The key file is generated with open ssh and it is in .ssh.

    If I try to connect it says that I have to tell the user and the public key passphrase. I put in the dedicated user of the server system and let the passphrase blank. Actually the login should work only with the private key file like I am used to. The passphrase for using the private key is not working. I tried this also.

    I want to change to NoMachine because lots of people around me love it and I think it’s a “layer eight problem”. And there are really not so much configuration options I think.. . Shame on me 🙂

    What I have tried

    – host syntax sd.sld.tld & ssh://sd.sld.tld

    – the specific port I am always using

    – protocol ssh

    – keybased authentication with my own keys

    -private rsa key /path/to/the/key (/home/usr/.ssh..)

    – import key into the connection file

    – transmit authentication & not to transmit authentication

    >>>>> authentication failed.. please try again..

    What am i doing wrong? greetings from berlin



    Hi Dennis,

    we are not aware of problems with private key authentication using NX protocol. You’ve mentioned ssh protocol and I am not sure from what you’ve written if this means you’ve tried to run an SSH connection to connect to the NoMachine server from the NoMachine player. Connections via SSH protocol are not possible with the free version of NoMachine, just to be clear.

    Can you tell us the version of openssh which you used to generate the RSA key? macOS version and Linux distro and version will also be helpful so we can try and reproduce here. Also useful will be screenshots of what how you have configured the NoMachine connection file (in the Configuration panel of the Add/Edit of the connection you are using).

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.