Not seeing Transfer Files option for MacOS

Forum / NoMachine for Mac / Not seeing Transfer Files option for MacOS

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #48209
    charlespc99
    Participant

    Hello,

    I need to transfer files from my local machine to the No Machine server that I have access to. I’m following the instructions from this article: https://www.nomachine.com/sharing-files-between-computers-with-nomachine. However, I do not see the “Transfer a File” option when I click on the !M icon. I also do not see the virtual clipboard when I have a NoMachine session open and look at the menu. Does this have to do with the version of NoMachine I have? I started using it last week, so I believe I have the latest version. Or, do I have to enable this option? If so, where do I need to go? Is there an actual reason why I do not see this option? Hope to hear a response soon.

    -Charlie Clark

    #48223
    Britgirl
    Keymaster

    Are you connecting to the remote NoMachine server using the browser or is this a traditional connection from inside the Player? I ask because you mention “virtual clipboard” and this is only available in web-based sessions.

    I do not see the “Transfer a File” option when I click on the !M icon.

    Are you clicking on the !M icon on the NoMachine server side? Start your session to the remote computer, click on the !M icon and take a screenshot if there is no file transfer option.

    Are you the administrator of the NoMachine server? Could it be possible that this option has been disabled on the server?

    #48224
    charlespc99
    Participant

    Hello,

    Thanks for the reply. I’m not using the web-based version to access servers. I attached a screenshot of what I see when I try to look for the “Transfer a File” option. It doesn’t appear when I click on the !M icon at the top right hand corner of my screen where I can also see the bluetooth icon and battery icon. I’m not an administrator of this server. I’m only a user. I’m not sure if this feature is disabled. Hope to a response soon.

    -Charlie Clark

    #48226
    Britgirl
    Keymaster

    Please submit that image to forum[at]nomachine[dot]com.

    You can check if file-transfer is enabled by going to Server settings from the !M icon on the remote desktop > Security > Scroll down to “File transfers” and check that the boxes are ticked.

    File transfers
    Allow clients to upload files – enabled by default, it ensures that others connecting to this computer can send files to the server.

    Allow clients to download files – enabled by default, it allows users connected to this computer to download files from the server.

    You can also see an example in Section 2.5 in the following guide https://kb.nomachine.com/DT07S00237#2.5.

    #48227
    charlespc99
    Participant

    I sent some screenshots to that email you provided. All of those options were checked off when I looked in the settings. So, I’m not sure why I’m having this problem. Hope to hear a response soon.

    -Charlie Clark

    #48234
    Britgirl
    Keymaster

    Thanks for the screenshots. I was not clear in what I wrote yesterday, sorry for that. When I wrote “You can check if file-transfer is enabled by going to Server settings from the !M icon on the remote desktop > Security > Scroll down to “File transfers” and check that the boxes are ticked.” – you need to do that on the Red Hat host you are connecting to, not on the Mac. The settings panel you showed us are the server settings for your own Mac (so if you were to connect to your Mac from another client, those settings control the upload and download of files from and to your Mac as a server).

    If you are not the administrator and can’t access the NoMachine server settings, you need to make a request to who is responsible for that machine. It is likely that file-transfer has been disabled in the configuration files of the server by whoever is (i.e the FT key has been set like this: EnableFileTransfer none in the node.cfg.)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.