Nx client disconnects

Forum / NoMachine for Mac / Nx client disconnects


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #31680

    I use NX to connect to a Linux system at work.  Since I upgraded to 7.0.211 if I minimize the NX window, it drops the connection, and I have to go through log in all over again.  The remote session is there to reconnect.  I’m running on an iMac with OSX 11.1 (Big Sur).  Can someone tell me how I can fix this?

    Also, for quite a number of versions, if I enter my username and passphrase and select the checkbox to save the passphrase nothing gets saved.  Can someone elucidate what’s happening here?  I’ve tried uninstalling and reinstalling NoMachine, but it doesn’t change anything.


    Hi. Does the disconnection occur as soon as you minimize the window, or after some time? Is the window disappearing when you minimize it, or it stays open with an error explaining the disconnection reason? In the latter case, what is the error?

    PS: I’m going to ask for details about the username/password problem in your other thread, to better split the topics.


    Here’s more information.  I logged on to the remote system this morning.  After doing a bit of work, I minimized the window.  Also, in the new version, I end up having to minimize 3 windows – one for the session, and the other two for preferences, which is a bit annoying.  I just did a test.  I clicked on the NoMachine icon on the dock, and it brought up the window with the connection lists (which has only one thing on it).  I connected and got a log in screen.  I logged in, then had to connect to an existing session. I then minimized the three windows.  But now, when I click on the “Connections” menu on the Mac status bar, it lists 4 connections to my remote system!  For 3 of them, the window is the login screen, but the 4th is the session.  So perhaps the new (?) user interface is just a bit confusing.  In the previous version of NoMachine, when I clicked on the icon in the dock, it just brought up the session.


    I figured out the problem.  Before I updated to the current version of NoMachine, I would minimze the NoMachine connection by moving my mouse to the upper right corner, where I could then access the page that let me minimize NoMachine by clicking on an icon.  If I came back to NoMachine by using command-tab it would then get back to the connection.  Under the new version, it wouldn’t.  It would, instead, get to the page that let me initiate a new connection.  I’ve changed the way that I minimize NoMachine by using command-tab to get to something that isn’t NoMachine, and then right click on the NoMachine icon in the dock, and then click on hide.  This was just a user interface confusion.  If there is a faster way to minimize my session, please tell me.


    A quick update on this topic. We continue to track this report even though we have been unable to reproduce it so far. It seems to be affecting this particular user’s set up which is strange. In the meantime, the topic has been closed but users can submit new topics if this behaviour continues on later versions of NoMachine.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as closed, you can't post.