NX Player for Android

Forum / General Discussions / NX Player for Android

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #5444


    first of all I want to say a big ‘Thank you’ for NX 4.x.

    Unfortunately in the last weeks it seems that the Android version of NX Player is quite ‘unresponsive’.

    Infact while on Windows and OSX everythings works fine, I cannot use the Android version anymore. After successful login I can see the remote screen for some seconds, then it freezes and after about 30 seconds it crashes. Since the Android version didn’t changed recently¬† guess there are changes in the Desktop version, since it worked before updating to 4.3.30.

    Is there something I could try to make it work again (beside clearing caches, uninstalling, reinstalling) ?












    Hi jnko.
    All 4.x versions are compatible so there must be something more. We’re investigating it. In the meanwhile if the client will crash again, could you please submit the crash report to Google by using the dialog appearing when the app closes? You may also add a little comment, so that we know that it comes from you. Thank you very much.


    Interestingly I downgraded to server version 4.3.23 it works again, but let me tell the full story.

    I ‘ve a Debian Wheezy 7.x (x64) Server running NX Server.

    From within the LAN (through a NAT-Router within the LAN or directly connected) I am able to connect to the Server from Windows, MAC and Android with recent client versions to NX Server version 4.3.23 (64Bit) and version 4.3.30(64Bit)

    From my Home network (NAT Router, 50MBit connection, no firewall at home, no firewall at Serverside) I am able to connect to NX Server ver. 4.3.23(64Bit) from Windows, MAC and Android recent clients

    With 4.3.30(64) I can can connect from home with Windows and MAC but not from Android.

    From Android (v 4.2.25) it is not possible to create a working connection to NX server ver. 4.3.30. (Confirmed on several Android devices).
    The connection itself works, I can see the initial remotescreen but then the client hangs, does not react to any touch gesture nor let me exit the client. While waiting for connection, which can take up to 5 minutes, sometimes it is not even possible to the Back-Key. Sometime I get a ForceClose.


    Where can I find client logfiles on Android or enable debug logs on Android (beside the very limited logcat output)?

    Now that I’ve a point to look further what exactly is going on I can make some tests in the next few days and provide client and server logs.
    NX 4 is exactly what I`ve looked for for many years – and know/watch for at least that 10 years . A mixture of cross platform VNC,RDP,Chrome Desktop. A product I really want to help to make it better and better.





    We’ve published an update on Play Store right now, as always it’ll be available in a few hours. This version fixes a freeze occurring sometimes when the client connects to the remote desktop. Can you try it and let me know if it solves your issue?

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.