NX Server on Mac, forces random sleep after long uptime

Forum / NoMachine for Mac / NX Server on Mac, forces random sleep after long uptime

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6832

    Client: NoMachine 4.5 on Windows (Win7x64)
    Server: Mac OS X 10.10.2 Yosemite

    sudo /etc/NX/nxserver --status
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.
    sudo /etc/NX/nxserver --version
    NoMachine - Version 4.5.0

    Problem: let’s say my Mac has been booted up fresh, nxserver/node/nxd are all running and I connect. Everything is fine. I do my work, then manually disconnect from the nx client.

    The better part of a day passes before I use it again.

    Now, if I’m not still connected, the machine name is no longer advertised on the network. No problem, I just plug in the static IP and login. Except…now the resolution that I had on my previous session is wrong. Well no big deal, I can change that easy enough. So I’m seeing my login screen on my Mac, I log in, and try to do my work.

    And then at random, the computer is put into display sleep. I could be typing mid-sentence and BOOM, black display. Wiggle the mouse or press a key and I’m again presented with a login prompt. So I log in again, and continue. Then, within a few seconds to a few minutes (seems to be random), BOOM, black screen. Cycle repeats.

    I’ve tried the following:
    – Disable screen lock. Doesn’t help, screen still goes black, it just doesn’t require a password to re-open my session (HUGE security problem!)
    – Turn off all the power saving options for when the computer is on battery (this is a MacBook Pro). No auto graphics switch. No hard disk sleep. Power nap is disabled. It WILL wake for network access and DOES prevent the computer from sleeping automatically if the display is off. The turn display off slider is all the way on the right to “never”.
    – I’ve upgraded NX server on the Mac to 4.5 in hopes that it would fix the problem. No help.
    – I’ve left the NX client open overnight on my main machine (a Windows box) in hopes that keeping the session open would prevent that. Either it gets disconnected or the same problem occurs when I send input into the nxclient.

    I’ve attached what logs I could find. When I originally set this up, I (perhaps rather unwisely) configured it to log to syslog, so all I can do is open up console.app and look for any entries with “nx” in there. That log file (with unique IDs sanitized) is attached.

    I’m going to revert that syslog change and have it log to its own location as the default, and see if it reproduces. I’ll add those logs here if/when this comes up again. Would appreciate any help anyone can provide. Thanks.


    We aren’t aware of this issue. We will investigate the problem.


    Thanks, kroy. I’m still struggling with it. I’ve found that in some cases, I can get the service back and working fine if I kill -9 all nx processes on the machine (this is as root) and then force /etc/NX/nxserver –stop to ensure everything’s disabled, then /etc/NX/nxserver –startup. That seems to “fix” the issue, but of course that requires either physical console access or another remote desktop solution to get into the system.

    Any help would be appreciated. Please let me know if you need any further information from my side to reproduce or diagnose. Thank you.


    Hi superduperdude,

    We have not been able to reproduce the problem so far.

    The logs could be helpful; can you please send a full set to forum[at]nomachine[dot]com (making sure you reference this topic) ?

    If needed, the procedure to follow is explained in the article “How to gather debug logs for support requests” (https://www.nomachine.com/AR07K00677)

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.