Nxd does not start from systemd, but does from ‘nxserver –restart’

Forum / NoMachine for Linux / Nxd does not start from systemd, but does from ‘nxserver –restart’

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46199
    jamat13
    Participant

    This was reported a while ago and was closed due to no response

    I have the same issue. I gathered all the info you requested. If you mail me I’ll reply with it all.

    James

    #46215
    Britgirl
    Participant

    Which distribution of Linux and its version do you use?
    You can submit logs to forum[at]nomachine[dot]com using the title of this topic as the subject of your email. Thanks.

    Desktop environment is also useful to know.

    #46217
    jamat13
    Participant

    Im using endeverOS which is arch linus.

    I found in the forum saying set PKGBUILD

    _autoservice=y

    This causes nxd to start from systemd and that resolves the problem. It may well be an arch-linux problem so solving it may be a waste of your time 🙁

    #46344
    Britgirl
    Participant

    This is not a NoMachine problem but one created by the Arch repository.

    You need to edit KGBUILD and set _autoservice=y and _autofirewall=n

    ### BUILD OPTIONS
    # Set to y to enable nomachine service autostart
    _autoservice=n
    # Set to y to enable firewall autorules
    _autofirewall=n
    ### END BUILD OPTIONS

    You can also just set this:

    sudo /etc/NX/nxserver --startmode nxd automatic

    and set in /usr/NX/etc/server.cfg

    EnableFirewallConfiguration 1

    after installation.

    Or better still, download and install manually from the NoMachine website:

    wget https://www.nomachine.com/free/linux -O nomachine_current.tar.gz
    
    sudo tar zxf nomachine_current.tar.gz -C /usr
    
    sudo /usr/NX/nxserver --install redhat
Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.