NXFrameBuffer failed to start on headless node after upgrade to version 7.7.4

Forum / NoMachine for Linux / NXFrameBuffer failed to start on headless node after upgrade to version 7.7.4

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #37115
    Axel Schweiger

    I updated my free NoMachine version on Ubuntu 18.04 to 7.7.4 from (6.5 I believe).

    This is a headless system.

    Only log entry I can find:

    27256 27256 2022-01-20 17:50:31 883.200 NXSERVER ERROR! NXFrameBuffer failed to start.
    28760 28760 2022-01-20 17:51:33 552.936 NXSERVER ERROR! Received error message from node ‘localhost:4000’, ‘Session failed, application terminated prematurely.’.

    I enabled debugging and attached log.  I tried reinstalling an older version for which I still had the package around (6.2) but no difference. Since I also installed a few recent Ubuntu updates I don’t really know what changed.

    Would be great if somebody could point me to how to solve this since I’m kind of stuck.

    Thanks very much in advance


    Axel Schweiger

    update on this. If I start the gdm3 or lightdm server by hand:

    systemctl start gdm3

    I get a display (however not with the right resolution). But I never had to do this, my understanding is that NoMachine has its own window manager, it appears that it fails launching (even though CreateDisplay is set to 1)

    I tried the switching between lightdm and gdm3 and also played with the enable Wayland option in the gdm3.conf file. No change




    Hi Axel,

    in the logs I see that NoMachine creates successfully the virtual X server, but gnome-session fails to start. I’d check the system logs for possible reasons. Feel free to share the logs with us. One thing you could try on the fly is changing the DefaultDesktopCommand key in the /usr/NX/etc/node.cfg file to add the ‘–disable-acceleration-check’ option to the gnome start command, e.g.:

    dbus-launch --exit-with-session gnome-session --session=ubuntu --disable-acceleration-check

    Axel Schweiger

    Thank you for your response and the suggestions. Unfortunately it doesn’t help. A peculiar thing is that when I look at the nxserver.log in the .nx directory of my home account, I notice the following:

     WARNING! Process ‘/bin/bash –norc -c exec -a – /bin/tcsh -c ‘dbus-launch –exit-with-session gnome-session –session=ubuntu” with pid ‘11334/11334’ finished with exit code 1 after 0,297 sec
    11282 11282 2022-01-24 10:29:49 110.973 NXNODE   ERROR! Application terminated too early.

    This seems to suggest that the edited command in the /usr/NX/etc/node.cfg isn’t even used? I verified that it is properly in the node.cfg file.   I removed the .nx directory in my home directory completely but that didn’t help either.

     grep -i dbus /usr/NX/etc/node.cfg
    DefaultDesktopCommand “dbus-launch –exit-with-session gnome-session –session=ubuntu”
    #CommandStartGnome “dbus-launch –exit-with-session gnome-session –session=ubuntu”
    CommandStartGnome “dbus-launch –exit-with-session gnome-session –session=ubuntu –disable-acceleration-check”
    # 1: Enabled. The node will use dbus-launch to run single commands
    #    which rely on dbus-launch for standard X session in order to let
    # 0: Disabled. Do not use dbus-launch for executing single commands.
    EnableDbusLaunch 1

    So where is the dbus command coming from if not from node.cfg?  Note that this is the free version and it seems like the node isn’t specifically configured. When I  (but I don’t really understand what’s going on there and how the node gets launched in this case.

    /usr/NX/bin/nxserver –startup
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    You referring to other logs to send, can you point me to what logs those would be?

    Not sure if this helps but I can start a gnome session just fine using xrdp on the same server. I actually can connect to it also via the NoMachine client.



    Axel Schweiger

    update and request for help on this

    As suggested I had added the –disable-acceleration-check to the default startup command and get this error in the .nx/nxserver.log . Don’t know why this didn’t work above. Must have messed up something. How can I debug this further, I really need to get this working again. Thanks!!!

    NXNODE   WARNING! Process ‘/bin/bash –norc -c exec -a – /bin/tcsh -c ‘dbus-launch –exit-with-session gnome-session –session=ubuntu –disable-acceleration-check” with pid ‘6763/6763’ finished with exit code 1 after 0,301 seconds.
    6709 6709 2022-02-22 11:21:46 976.084 NXNODE   ERROR! Application terminated too early.
    6709 6709 2022-02-22 11:21:47 008.287 NXNODE   ERROR! Session application terminated abnormally

    From <https://forums.nomachine.com/topic/nxframebuffer-failed-to-start-on-headless-node-after-upgrade-to-version-7-7-4>



    we have checked Ubuntu 18.04 and don’t have any issues, with its default installation, that is. I don’t know if you have changed something or not. Have you tried uninstalling NoMachine and removing the /usr/NX directory before reinstalling? What’s the GUI you are using? Check with:

    grep ^Exec /usr/share/xsessions/*.desktop

    The current version of NoMachine is now 7.8.2.

    Axel Schweiger

    Thanks for looking into this. Much appreciated.

    I have removed the NoMachine package (apt remove –purge), removed the /usr/NX and ~/.nx directories and reinstalled and tried 7.8.2. The result so far remains the same. It appears that the start of the xsession is unsuccessful.  The

    /usr/NX/etc/node.cfg file has this command

    CommandStartGnome “dbus-launch –exit-with-session gnome-session –session=ubuntu –disable-acceleration-check”

    and the

    ~/.nx/nxserver.log  has multiple entries like this:

    21842 21842 2022-02-22 15:29:35 862.181 NXNODE   ERROR! Application terminated too early.
    22261 22261 2022-02-22 15:30:37 499.466 NXNODE   WARNING! Process ‘/bin/bash –norc -c exec -a – /bin/tcsh -c
    ‘dbus-launch –exit-with-session gnome-session –session=ubuntu –disable-acceleration-check” with pid ‘22338
    /22338’ finished with exit code 1 after 0,247 seconds.

    So it appears that somehow the starting of the ubuntu desktop session crashes when launched.

    The output from : grep ^Exec /usr/share/xsessions/*.desktop
    /usr/share/xsessions/ubuntu-communitheme-snap.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu-communitheme /snap/communitheme/current/session
    /usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu gnome-session –session=ubuntu

    Note that I can connect to this system with a NoMachine client fine when starting the xsession separately. I have used xrdp (Windows Remote Desktop server). Windows Remote Desktop seems to start the session  and then I can connect with the Windows NoMachine client. This is my current workaround, which might be useful to know for others who have “headless” issues.



    Hi Axel,

    did you check the system logs? They could show some hints. You can use the ‘journalctl -b’ command for that. Feel free to send the output to us so we can check.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.