Nxserver can’t start on Opensuse 13.2

Forum / NoMachine for Linux / Nxserver can’t start on Opensuse 13.2

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #5764


    i’m using NoMachine on opensuse for years, but since the last opensuse 13.2 update, no way to launch nxserver.

    I tested on a fresh install in a VM also without success.

    Config: Opensuse13.2/x64 – NoMachine free 4.4.1 (tested also with 4.3.30)

    service launch:

    service nxserver start
    vm122:~ # service nxserver status
    nxserver.service – LSB: Starts and stops the NoMachine NX Server.
    Loaded: loaded (/etc/init.d/nxserver)
    Active: active (exited) since Thu 2014-12-18 10:26:20 CET; 10min ago

    Dec 18 10:26:20 vm122 nxserver[13114]: NX> 161 Enabled service: nxserver.
    Dec 18 10:26:20 vm122 nxserver[13114]: NX> 500 ERROR: Cannot start service: nxnode.
    Dec 18 10:26:20 ag122 nxserver[13114]: NX> 500 ERROR: Cannot start service: nxd.

    Here is the error in /usr/NX/var/log/nxserver.log:

    2014-12-18 10:34:39 081.128 13446 NXSERVER ERROR! Cannot open socket on port: 20279 Cannot assign requested address
    2014-12-18 10:34:39 081.158 13446 NXSERVER ERROR! Cannot start listening on server monitor socket.
    2014-12-18 10:34:39 089.001 13432 NXSERVER WARNING! Service: ‘nxserver’ is not started, no process running with pid ‘13446’.
    2014-12-18 10:34:44 917.413 13458 NXSERVER Shutting down NoMachine server and services.

    And in /usr/NX/var/log/nxerror.log:

    13446 13446 10:34:39 080.971 Socket: WARNING! Can’t bind the IPv6 socket.
    13446 13446 10:34:39 080.999 Socket: WARNING! Error is 99 ‘Cannot assign requested address’.
    13446 13446 10:34:39 081.033 OpenSocketToListen: WARNING: Can’t bind to port: port 20279, error is: 99 , EADDRNOTAVAIL.

    The error seems related to port assignement and ipv6, I tried to disable firewalling & ipv6 without success.

    Thanks for your support,



    Hello dvpaul,

    we are not able to reproduce your problem in our labs. It may be due to your network interface configuration, from the logs you posted it’s hard to tell.

    Could you please increase logs level by setting SessionLogLevel key in your /usr/NX/etc/server.cfg and /usr/NX/etc/node.cfg and send the entire contents of /usr/NX/var/log to us?

    Instructions on how to collect logs: https://www.nomachine.com/AR10K00697

    Send everything to issues[at]nomachine[dot]com and reference the topic title in your subject.





    I had the same problem on my Kubuntu 14.04 station.

    I enabled the logging level 7 and, after having a look at the logs, I finally figured it out and managed to get it to work; unfortunately, the reason it was failing on my machine is so dumb, I am embarrassed: it seems that for some unknown reason, my /etc/hosts did not have an entry for the localhost (which caused some failures when starting up the servers).

    If you get unknown host when you ping localhost, then you have the same problem. Just saying…

    I had many lines like these in the log:

    29593 29593 18:40:27 660.272 Io/Io: WARNING! Error is 99, ‘Cannot assign requested address’.
    29593 29593 18:40:27 660.304 OpenSocketToListen: ERROR! Unsupported address family.

    that gave me a hint of what was going on.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.