Nxserver –daemon is not ready

Forum / NoMachine for Linux / Nxserver –daemon is not ready

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #16795

    Hi, I tried to install NoMachine for linux rpm ver. 6.0.66_2_i686 on CentOS6 kernel 2.6, but had a problem on starting the server.

    I have just followed the instruction on the web (https://www.nomachine.com/DT02O00124), running rpm command, and the installation seemed successful. However, looking at NoMachine Service Status GUI, Server is indicated as stopped (when logging in as root) or not running (others).

    There are message in /usr/NX/var/log/nxserver.log as follows (once I have restarted, but failed).
    2017-12-05 19:05:23 464.740 429 NXSERVER WARNING! Timeout 60s when waiting for nxserver –daemon.
    2017-12-05 19:05:23 465.097 429 NXSERVER WARNING! nxserver –deamon is not ready.
    2017-12-05 19:25:59 863.356 5797 NXSERVER Shutting down NoMachine server and services.
    2017-12-05 19:27:00 498.683 5797 NXSERVER WARNING! Timeout 60s when waiting for nxserver –daemon.

    What I did on installation was just running a command “rpm -ivh nomachine_6.0.66_2_i686.rpm” as root user.

    Is this enough or any other setup required to run the service?

    I have switched off firewalls and SElinux, but the result was same.


    we would also expect different results just after installing. There are not any additional steps required.

    You used package i686 which is for 32bits platforms only. If your Centos system is 64bits
    then please uninstall and download/install package with the x86_64 extension.

    If this is not a case then something did go wrong and we need to take a look at the logs. So, please follow article:
    https://www.nomachine.com/DT10O00163 and share with us logs by sending them to forum[at]nomachine[dot]com.



    Oops! It was just my mistake of using wrong package.

    Now it works well.

    Thanks brotech.



Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.