NXservice preventing scheduled shut down task?

Forum / NoMachine for Windows / NXservice preventing scheduled shut down task?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #47984
    SaranWrap
    Participant

    I just came across NoMachine and installed it on my media server on my LAN. (Wow, where have you been all my life!)

    Other than this Windows 10 Pro, version current media server having an Internet connection, it does NOT have any outside connections, no remote access, etc.

    Since the installation of NoMachine two days ago, I have found that my daily 10:00pm shutdown task is not completing. This is not the end of the world, but it does help with my electric bill.

    I would make a poorly educated guess that the NXservice doesn’t want the task shutting down the computer, which of course would prevent remote access. I have tried and failed to find a way to assure NoMachine that this is an acceptable function and that it should be allowed.

    I’m not completely challenged by computers and have heard of Google. That having been said, I’m a bit stumped and unsure how to proceed. Any help would be greatly appreciated!

    #47988
    katpan
    Participant

    Hello,

    thank you for your post.

    NoMachine prevents a shutdown/sleep only when the session is active. Can you please try without an active session?

    #47990
    SaranWrap
    Participant

    NoMachine prevents a shutdown/sleep only when the session is active. Can you please try without an active session?

    That’s the one thing that I managed to NOT say, I guess. The computer itself was/is running, but nothing was connected to it that I am aware of – there should not have been an active session unless there is something in the computer install that causes NoMachine’s service to constantly watch for a connection?

    I can see that being the case, but can’t find a setting related to it.

    #48331
    Britgirl
    Keymaster

    The next time it happens:

    Press Windows key + R to open up a Run dialog box. Then, type “eventvwr.msc” and press Enter to open up the Event Viewer utility.

    Inside the Event Viewer utility, use the left-hand side menu to select Windows Logs. Then, double click on Application to bring up the Application events in the right-hand side pane.

    Inside the Application section, look for an event that states “The following application attempted to veto the shutdown” in the General tab (under the list of events). Since you’ve just forced the warning message to appear, it should be one of the very first listings since the default order is by date/time.

    You will be able to find the executable that is causing the warning message. Tell us what it is.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.