One key press causes multiple keys on the Server (NX v4.2.24)

Forum / NoMachine for Windows / One key press causes multiple keys on the Server (NX v4.2.24)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #4627


    Unfortunately the original thead (“One key press causes multiple keys on the Server”) was closed and the problem was not resolved, the initiator of the thread gave up before the issue could be tracked down.

    Furthermore there’s a KB article about this issue which says the problem was “solved” in v4.1.28.

    Unfortunately it wasn’t.

    I’m using a Windows 7 client with NX v4.2.27 (free version) and an Ubuntu 14.04.1 server with NX v4.2.24 (free version) and the problem is still present. I’ve already increased the key repeat delay (and decreased the key repeat rate) on both the Windows client and the Ubuntu server, but it didn’t help. I’ve tried disabling UDP connections since in the original thread the explanation of the issue was that sometimes key release signals/events don’t reach the server, thus a key gets “stuck” on the server side, but it didn’t help. I can confirm this … since I experience not only character repeats (words like “hhhellloooo” 🙂 ), but also stuck shift key which results in all capital letters … til I press the stuck shift key repeatedley (so the NX server’s shift state gets synchronized with the client’s shift state)

    The user “titan” (I assume she/he works for NoMachine) suggested that she/he could provide a test build with further logging that could shed light on the issue. If the proposal still stands, I’d like to help to debug the issue. I can (unfortunately) reproduce it all the time.

    Best regards,Zsolt


    Hi Zsolt,

    we are testing again the solution to that Trouble Report in our labs, but we are unable to reproduce any problem so far, so it has to be some corner case. The user who originally reported the problem never got back to us.

    We are preparing a test build for you to test. In the meanwhile, can you try to disable the autorepeat completely by the “xset r off” command on the Ubuntu remote server? Just to exclude the possibility we are looking in the wrong direction… 🙂


    Hi Zsolt.

    The test build is ready. Please write to issues (at) nomachine (dot) com in order to get it.

Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.