Ooops could not start the display

Forum / NoMachine for Linux / Ooops could not start the display

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #4038

    Hello all

    I’m actually facing a strange behavior and searching google or digging the forum is not answering it (may be I’m searching with my feet ? :))

    Server and client (emachine) are ubuntu 14.04 based, both running NoMachine_4.2.25.
    Client is running unity, and server is up to date with lxde set. My client was connecting some time ago, and since a full reinstall I’m getting the message “ooops, could not start the display” after the login form.

    I though it was the server, but I tried from another machine (tablet android !by the way what an incredible job !) and it was perfectly working without any modification. So I deleted everything on the first client (home/.nx) and uninst and inst again. But I still get the same error.

    The error log is … empty, only “No LSB modules are available.” when service is launching.

    I noticed another strange thing, may be a clue : on the tablet, when using the wizard, I can see some display options like resizing or keeping server display, but on the emachine I don’t, no option for that.

    any great idea for me someone ?

    thanks in advance …


    Hello fjunillon.

    Could you gather the complete set of logs? Look at this article:



    thanks for the reply. I did not push the logs as I checked them and nothing could be identified in, even in verbose debug mode.

    Finally I have tried a last time, all removing, cleaning and so on, then have it reinstall. No way, it was not working. As my needs where not professionnal I removed it from servers and client days ago and installed another free one probably less competitiv but actually working on my config


    Maybe you installed the wrong product. Did you install Workstation or the free NoMachine for Linux? They are different products. You mention that you were able to connect some time ago. Were you using the 3.x version? If so, what you need is the Workstation in version 4.


    what I download and used was the nomachine_4.2.25_1

    The only difference is that I used the _i386 on the master (ubuntu 32) and _amd64 on the client (ubuntu 64) .

    Was I wrong ?

    I checked in a backup and yes, you are right I was using a version 3x. It was the same master but the client was OSX.


    one more point : I downloaded it from Free remote desktop (


    The product you downloaded is the free NoMachine for Linux which gives access to the physical display. If you want to use it on a headless server, just follow the instructions here:
    If you want to connect to a virtual desktop (like you did with version 3, assuming you were using the free version back then which was the NX Free Edition), then you need the Workstation as I already mentioned.

    I don’t think you had problems because the software didn’t work (it works out of the box) , it’s because you downloaded the wrong product.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as closed, you can't post.