Ooops! The connection to the server was lost

Forum / NoMachine for Linux / Ooops! The connection to the server was lost

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8222
    Sim81
    Participant

    Hello,

    I am trying to connect to a virtual machine in AWS EC2, but I get this message from NX client: Ooops! The connection to the server was lost.

    Attached you can find the log file, please help!

    Thank you

     

     

    #8240
    Haven
    Participant

    Hello Sim81,
    In attached NX Network server (nxd) logs we can find:

    Error: Error 98 'Address already in use'.

    The default setting of NoMachine is to run connections is via the NX protocol on port 4000.
    Did you try to change default NX port?
    You can do it by editing /usr/NX/etc/server.cfg file:

    #
    # Specify the TCP port where the NX service is listening.
    #
    #NXPort 4000

    uncomment and change this default value from 4000 to 4001.

    After that please execute /etc/NX/nxserver --restart to apply changes.

    Please remember to update port value also on nxplayer side.

    • This reply was modified 8 years, 9 months ago by Haven.
Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.