OpenSUSE leap 42.1 with KDE plasma 5

Forum / NoMachine for Linux / OpenSUSE leap 42.1 with KDE plasma 5

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #11618

    When I connect to my server running openSUSE leap 42.1 all I get is a blank screen. It does connect though and I do see the “user max has connected” popup from NoMachine on the server but that is all I see, there’s no taskbar, no desktop background, no icons literally everything except that popup is black. Also the popup appears at the top left of the screen for some reason.

    The only thing that made this work was connecting the server to my TV with an HDMI cable. Didn’t matter that the TV was off, NoMachine still worked. As soon as i disconnect the HDMI and try to connect with NoMachine its back to seeing blackness again.

    Is this an openSUSE issue or NoMachine or maybe KDE5? Anyone else experienced this or have any idea why this happens or how to solve it?

    NoMachine version = nomachine_5.1.26_1_x86_64.rpm

    Problem arises connecting to virtual display (i assume this is what it means when no actual monitor is connected?)

    Remote OS = openSUSE leap 42.1 fully updated

    Local OS = windows 10 64 bit fully updated

    openSUSE KDE plasma version: 5.5.5

    Centos 7 and Debian 8 work perfectly, I think this is isolated to either OpenSUSE or KDE5 since both Centos and Debian are still on KDE4



    the problem is that the graphics card stops working when the cable is unplugged, and the X server stops rendering properly.

    You can work around this problem by trying the instructions in this post:×768#post-11035

    If you stop the lightdm service, for example, NoMachine will create a virtual display that will work without problems.


    Yes the problem definitely manifests when I yank the HDMI cable.

    Seems that SDDM is the display manager being used in KDE5. I tried disabling it with putty (just learned to use ssh today, its so useful!) but I still get this:

    View post on

    VNC also gives a blank screen. Although like NoMachine it does appear to work.


    Managed to solve it by setting the nomodeset kernel parameter.


Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.