Paste from clipboard trailing with NUL character

Forum / NoMachine for Windows / Paste from clipboard trailing with NUL character

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #31091


    Recently I upgraded my Windows NoMachine to the latest version 7.0.211_4. I found when I worked on the remote machine, pasting texts copied from the client resulting in a NUL character trailing. This is pretty annoying because not every time the NUL character is visually shown. And this character can cause various problems. I attached a screenshot showing this problem. It is when using PyCharm.

    I also tested using a Mac as a client, and there is no such bug. And after I downgraded my Windows client to version 6.6.8, this problem disappeared.

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).

    Local: 7.0.211_4
    Remote: 7.0.211_4
    Both are free versions

    – Whether the problem arises connecting to a physical or a virtual display.

    Virtual display

    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).

    Local: Windows 10
    Remote: Ubuntu 18.04

    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    Remote desktop: GNOME


    We’ve reproduced the problem and opened a Trouble Report which you can track using the following link:



    The TR associated with this forum post was closed in the software release 7.1.3.
    Copy paste from Windows or macOS client ends up with a NUL character with PyCharm

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.