Pi connecting but not displaying desktop environment

Forum / NoMachine for Raspberry Pi / Pi connecting but not displaying desktop environment

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #48092
    Zak
    Participant

    I am running a 64bit RP4 Bookworm. I am able to connect from a Mac over the same Wifi (still troubleshooting doing this over the internet). I can login to the Pi and the connection is made (I can see the connection is made both on the Mac and on the NoMachine running on the Pi).

    Unfortunately that’s as far as I get. The next screen switches between issues:

    Occasionally it shows an active Desktop Environment to select, but then times out with a white screen and says ‘the connection was reset by peer’

    But mostly, when I connect it just shows ‘Server does not have a Desktop Environment to display’ (or something like that).

    I don’t see any configuration option in NM which handle desktop environments.

    The Pi does have Light Desktop Manager running and I can see the UI on a monitor connected directly to the Pi.

    #48096
    Britgirl
    Keymaster

    This might be related to a known issue for which we have a Trouble Report open, but we’d like to check the logs first if that’s possible. Can you send us the NoMachine logs from the Raspberry device? You can extract them using the instructions here: https://kb.nomachine.com/DT07S00243. Logs from the Mac client as well can be useful as well.

    Send them to forum[at]nomachine[dot]com. Please use the title of this topic as the subject of your email. Thanks!

    Then after that can you try disabling Wayland? This is the link to the issue already known.

    Black screen when connecting to Raspberry Pi boards
    https://www.nomachine.com/TR10U11031

    #48136
    Zak
    Participant

    I’m sorry I never uploaded the logs. I am not very technical and was having a lot of trouble. I was eventually able do the Wayland fix and it worked. In case anyone else is experiencing this, my screen never went black like the original Issue described for that fix. It was white and kept trying to establish the desktop, but would time out and say Connection reset by peer… and then try again, in a loop.

    Thanks for the help!

    #48142
    Zak
    Participant

    My next issue was trying to get it to run over internet. I have tried Port Forwarding, Port Mapping, using NX and using SSH, I have tried using the UDPnP automatically and manually and have scoured the config files for something I’m missing.

    I can see my external IP address and have tried many combinations of that plus :4000 and other ports, but NM keeps indicating that I should use 0.0.0.0:port

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.