Please add an option to hide the local cursor

Forum / NoMachine for Mac / Please add an option to hide the local cursor

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #48284
    tinywolf
    Participant

    The local cursor is displayed ridiculously large. I only want to see the remote cursor. I need an option to hide the local cursor.
    Please.

    #48294
    tinywolf
    Participant

    The local cursor covers a lot of the screen.

    #48296
    bucu
    Participant

    Hi,

    can you tell us what macOS and NoMachine versions are you having this problem on?

    #48308
    tinywolf
    Participant

    MacBook Air M1, 2020

    macOS Sonoma 14.5

    NoMachine 8.11.3

    However, this has been this issue since the previous versions.

    I asked in this forum last year #42709

    #48365
    bucu
    Participant

    I assume macOS is the client, what is the server machine you are running your session on? Is there any system display scaling enabled there? Are you, by any chance, running a nested session (you are connected to a server and have opened a new connection from that server)?

    #48375
    tinywolf
    Participant

    No nested session.

    2 server machines. Wbuntu 22.04, MS Windows 11. Both machines have the same problem.

    I use mainly “scale to window” and “fullscreen”. But, the issue occurs in any option state.

    I’m using a size-up cursor on the server machines.

    in MS Windows 11 -> attached image

    in ubuntu 22.04 -> attached image

    #48432
    bucu
    Participant

    I wasn’t precise enough when asking about scaling: I didn’t mean cursor scaling alone, I meant scaling in the system display settings. Can you please clarify that maybe with a screenshot?

    That said, we couldn’t reproduce your problem in our labs. Can you send us zipped logs from following folders on the server side while the problem occurs:$HOME/.nx from linux or %USERPROFILE%\.nx from Windows?

    Please send them to forums[at]nomachine[dot]com

    #48454
    tinywolf
    Participant

    I have found the cause of this issue. It was the client-side mouse pointer size. When I changed the pointer size on macos to 100%, the remote and local cursor sizes are same. But when I increased the pointer size on macos to 400%, the local cursor became too large. I want to use 400% cursor size on the server side and 400% cursor size on the client side too. Can you please give me an option to hide the local cursor or make it a dot pointer in the NoMachine’s client settings?

    Attachments:
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.