Prevent automatic viewport scrolling

Forum / NoMachine for Windows / Prevent automatic viewport scrolling

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #46576
    Tim Yuan
    Participant

    I have a two monitor Windows machine that I use to access a virtual Linux machine.

    I desire to have the Linux desktop span across both monitors sometimes and to display a cropped desktop when only using one monitor. This is works.

    When displaying on one monitor, the desktop automatically scrolls when the mouse goes to a side. I desire not to have this automatic scrolling, but to manually adjust the scroll bars.

    I have added the following to both the Windows .nxs file and the Linux player.cfg file but the auto scrolling still happens. Is there something else that needs to be set to stop this automatic scrolling?

    Virtual Linux machine is : Redhat 8.4/Gnome

    Windows machine is : NoMachine Enterprise Client Version 8.10.1

    Other setting in windows .nxs file

    Other settings in linux ~/.nx/config/player.cfg file

    #46588
    Tim Yuan
    Participant

    urr command syntax is not shown, trying again

    Other setting in windows .nxs file
    <option key=”Physical desktop resize mode” value=”viewport” />
    <option key=”Virtual desktop resize mode” value=”viewport” />
    <option key=”Automatic viewport scrolling sensitive area size” value=”0″ />

    Other settings in linux ~/.nx/config/player.cfg file
    <option key=”Automatic viewport scrolling sensitive area size” value=”0″ />
    <option key=”Enable view all monitors shortcut” value=”true” />
    <option key=”Server list view mode” value=”children” />
    <option key=”Show scrollbars in viewport mode” value=”true” />

    #46644
    Tim Yuan
    Participant

    Maybe disabling auto-scroll is no longer supported? Suppling code versions in case it matters

    Linux Server:
    Redhat 8.4/Gnome
    NoMachine Monitor version (aka NXAGENT) ‘8.5.3’

    Windows Client:
    Windows 11 Enterprise
    NoMachine Enterprise Client: 8.10.1

    #46670
    Tor
    Participant

    Close all your client instances on Windows and change the following key in %USERPROFILE%\.nx\config\player.cfg by setting its value to “0”:

    <option key=”Automatic viewport scrolling sensitive area size” value=”0″ />

    The viewport scrolling is configured only on the CFG file and only on the client, any other changes you did can be reverted/ignored.

    #46688
    Tim Yuan
    Participant

    Thanks, but unfortunately tried this and it didn’t work. Perhaps this feature was backed out for some reason. Maybe I’m the only strange one that doesn’t like automatic stuff.

    #46695
    Tor
    Participant

    The feature is still there and working correctly, so we should just understand why it is not working for you. By the way your preference is perfectly legit! I keep the value set to 10 for a similar reason.

    First of all we’ve to verify if the problem is caused by some unexpected values in the CFG and NXS files.
    The NXS can be reset to default values by creating a new connection to your server. Don’t worry about your other custom settings, you can set them later.
    The CFG can be reset with the “Restore default player settings” link in the settings window. Once you do that, close the player from the tray menu, and edit the CFG like I said in my previous answer.

    If also this solution doesn’t work, try to set a value slightly bigger than 0, for example a number between 1 and 5, and confirm that the automatic scroll starts when you’re very close to the window edges. This test could be helpful to verify whether the problem is in the setting value reading, or in the logic of the automatic scrolling.

    #46858
    Tim Yuan
    Participant

    FYI: After much trial and tribulations, I have given up on this feature. I will just implement single monitor solutions

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.