Prevent from logging on machine where a user is already logged in ?

Forum / NoMachine for Linux / Prevent from logging on machine where a user is already logged in ?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #26490


    (using entreprise cloud edition webplayer)

    I’d like to know if there is any way for users to know if another user is already logged in on a PC and prevent him to log to it.

    Something like machine icon greyed in web interface, or not visible, not clickable…

    Thanks for your help




    Preventing a user from logging in to an ED is achieved by ensuring that a user always logs in to the same host. You do this by setting “forward connection” to the specific ED for a particular user. If admin sets this for all users, then you can avoid showing ED hosts which are available and/or unavailable: the user will simply go the to ED which is for him only.

    root@cs3:~# /etc/NX/nxserver –useredit adam –forward-connection ed1
    NX> 106 Modifying settings for user: adam

    root@cs3:~# /etc/NX/nxserver –userlist
    NX> 149 NX users list

    Username   NX administrator Redirected to Trusted physical for Trusted virtual for Screen sharing Access  Forwarded to
    ———- —————- ————- ——————– ——————- ————– ——- ————————————
    adam                                                                            enabled        enabled 9de912ca-ae7b-45c2-8234-f75d363b086f

    How user adam will connect to ED1? It depends on the serveradd options which are ‘ –forward-nx-methods token|system|tunnel’.
    ‘token’ and ‘system’ mean that nxplayer will disconnect from CS and connect directly to ED1, where tunnel
    means that whole connection will go through CS. You can check how your forwarding methods are set using:
    /etc/NX/nxserver --serverlist

    and modify using /etc/NX/nxserver --serveredit

    There is a FR03R03953, “Displaying the number of users connected to the child servers”
    which should be release soon in a maintenance update for v6. This might be of interest to you as well.


Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.