Problem connecting from Windows to CentOS

Forum / NoMachine Terminal Server Products / Problem connecting from Windows to CentOS

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #39571

    Hi all,

    I have computers with Windows 10 and a server with CentOS 7.9.2009 (Core). I install the Small Business Server on the Linux computers and connect to it on the Windows computer.

    Recently I added a new server node and tried to connect to it as usual. However, this time I get the error and cannot connect to it.

    I get:

    “A connection timeout has occurred while trying to connect to ‘’ on port ‘4000’. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.”

    I do not understand what happens. I made the same installation as I had done on other nodes, following the instruction, which had worked well. I tried to search the solution for it on the forum but failed. Can anyone help solving this?

    Here I attach the logs. Thanks!



    It looks like you are trying to connect over the internet to the server host. Port 4000 can be used in local connections, but if you want to use it in the connection from external network – you need to open that port on the router manually. More info about how to connect over internet you can find there:


    Thank you for your answer. However, it seems not working. I cannot make the connection even with the computer which is in local connections.


    So you have the Small Business Server v7 installed on the computer you want to connect to? From your Windows client, when you open NoMachine, can you see the Small Business Server machine in the Machines panel?

    Please submit screenshots or describe the steps you are taking to connect from your Windows client to the NoMachine server via LAN.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.