Problem installing NoMachine for Ubuntu MATE

Forum / NoMachine for Raspberry Pi / Problem installing NoMachine for Ubuntu MATE

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #34451

    Welcome, everyone!

    Its my first post here, so I’m Vlad. Noob in the Raspberry Pi world. Please be gentle with all my questions. 😉

    I got Pi 4B and trying to setup my Raspberry as remote machine. I download and installed Ubuntu-MATE (latest available).

    There was no problem with installing it. Then I tried to install NoMachine…not possible to install.

    I tried to download :  NoMachine for Raspberry Pi 4 / .ARMv7.DEB  also tried .RMv8.DEB

    Same problem, installing package gave me info that package is not supported or package installation tool was trying to open two windows for the same downloaded package? How is that possible, what am I doing wrong?

    So I changed OS to latest Ubuntu 20.x (chosen from Raspberry Pi Imager. Sam issue. Not possible to download or install anything.

    I tried that on intel/Ubuntu 18.04.  There was no problem at all.

    Thank you for any help.



    Hi Vlad! Welcome to NM Forums 🙂

    I suggest you check your architecture using the command below :
    uname -m

    if it shows:
    a. arm64

    then try:

    wget -O nomachine-armv8.deb
    sudo dpkg -i nomachine-armv8.deb

    if it shows:
    b. armv7l

    then try:`wget -O nomachine-armv7.deb
    sudo dpkg -i nomachine-armv7.deb`

    Let me know the outcome. If it still doesn’t work, please paste the outputs of those commands here and check also md5sum. Thanks!



    Thank you so much for all those tips. Already tried that. This is what I did.

    Download and installed RaspberryOS 32bit and use various commands to identify my CPU, it showed me ARMv7l.

    ARMv7l is 32bit CPU. I installed NoMachine on that OS and it worked fine. No issues except extreme lagging.

    But, Is it possible to have 32bit ARM CPU on Raspberry Pi 4B 8GB ?

    So, I installed latest Majgaro ARM for RaspberryOS …and checked my CPU again… and guess what it showed ARM64.

    How is that possible?

    I couldn’t install NoMachine on Manjaro using DEB package.

    Will dig more into this. I’m shure the explanation should be somewhere. Or on the Raspberry side or NoMachine.

    Did anyone try to use latest Ubuntu 21.04 (64bit) with NoMachine?


    Hi Vlad,

    RPi4 is ARMv8 board. You can find more information here:

    It’s possible to install ARMv7 OS on ARMv8 board.
    From the NoMachine side – it’s important to choose the correct installation architecture, exactly like with other applications.

    When it comes to Manjaro – which is based on Arch – just install tar.gz file (don’t forget to choose the correct architecture):

    NoMachine works fine also on Ubuntu 21.04 (ARM64).


    Small success I guess.

    I decided to install latest Ubuntu 21.04 64bit once again (available from RaspberryPi Imager).

    uname -m   showed me (same as Manjaro)  ‘aarch64’ as my arm CPU.

    cat /proc/cpuinfo  = BCM2835 (revision:d03114)

    Then I download NoMachine ‘ARMv8…DEB’ file but this time I decided to use GDebi tool to install my DEB package.

    And all went pretty good. Finally NoMachine was installed on my Raspberry Pi 4b (rev 1.4, 8GB).

    After few tests must say NoMachine works pretty stable on Ubuntu 21.04 64bit. And a lot faster then on RaspberryOS 32bit. Now will do more tests from Windows and Ubuntu 18.04 under VPNs etc. Hope it will run smooth as well.

    Another thing I noticed that one of my core is running 100% full even if Raspberry is in idle mode (no applications running).

    That 100% core is changing in time. Once it is 1st core, then 2nd, then 3rd then 4th…in cycle.

    I see this on ‘htop’ and ‘System Monitor’… but there is no process running at 100% CPU.   Another interesting issue to solve.

    Thanks for your help Carin!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.