Problem with attaching USB device in any OS X version

Forum / NoMachine for Mac / Problem with attaching USB device in any OS X version

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #9633

    Hi @all,

    I’m experiencing some strange problems using USB pass-through with the following configuration:

    Host System: Windows 7 Professional x64 with NoMachine 5.0.58, physical PC

    Client System: OS X 10.11.2 with NoMachine 5.0.58, VM in VMware Fusion 8.1.0

    I’m aware of the fact that one has to “whitelist” the specific OS version in the configuration file (/Applications/NoMachine/.app/Contents/Framework/scripts/restricted/….so I did and in fact I am now able to attach and access a USB thumb drive to this Virtual OS X.

    Now the exact problem which I get here is that I need to attach and access an Apple iPhone in this VM…this is not even possible. Attaching the device is working, NoMachine is giving a green symbol like it did with the thumb drive but I’m not able to access the iPhone via iTunes or Photo-app.


    1. In terminal I checked if the iPhone is connected via “ioreg –p IOUSB” …it is!

    2. The iPhone is asking to “trust” the device, like it always does when attaching to OS X or Windows with iTunes installed. (connection “halfway” established?)

    3. Tried it with and without VMware Tools, doesn’t matter (USB drivers for the created hub are delivered with NoMachine??)

    4. This is reproducible with OS X 10.9 up to 10.11, minor versions doesn’t matter.

    5. When attaching the iPhone via VMware Fusion (physical) it is recognized in iTunes etc. but this isn’t the goal, because in future the system isn’t physically accessible.

    I would appreciate any help.




    There is a Trouble Report on this issue which you can see here:

    There is also a workaround documented. The workaround works only for Mac OS X versions included in file (/Applications/

    OS X 10.11 will be added as soon as issues regarding USB forwarding are solved for this version (

    Please use the notify me to know when fixes have been released.


    Thank you for your fast response and solution. Excuse me, I didn’t found this Trouble Report(s) and sorry for answering so slowly.

    First of all, I have to admit that my description about the OS X versions wasn’t right, with OSX 10.9 and 10.10 I was able to successfully connect the iPhone via the USB passtghrough. The workaround is working… as described in the TR you just have to reconnect the iPhone via NoMachine-menu.

    With OS X 10.11 I was able to connect a USB thumb drive (after editing and as previously stated the iPhone is connected (check via terminal “ioreg -p IOUSB) but didn’t show up in iTunes or other apps… I’ll keep on waiting eagerly 🙂

    btw: also tested the new release 5.0.63



    I will close this forum post now. Users can follow the link to the Trouble Report and use the ‘notify me’ feature to know when a patch has been released.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.