Problem with NoMachine on Lubuntu 16.04.4

Forum / NoMachine for Linux / Problem with NoMachine on Lubuntu 16.04.4

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #19410

    Hello 🙂

    I’m using NoMachine on Lubuntu, the problem is that the WAN server doesn’t appear for the connection here:

    View post on

    Doesn’t appear when I start the computer because when I go into server preference I need to open manually the gateway port…but even if I open that the server for WAN connection don’t appear.

    I also open the port on router but don’t work anyway:

    View post on


    By the default NoMachine use port 4000 (more about NoMachine’s default ports you can find there: and it should be used as “LAN Port” in your case.

    But to avoid possible problems with port forwarding manual configuration we suggest to restore all your previous changes and enable UPnP on the router and on nxserver. To do that last – edit server configuration file (/usr/NX/etc/server.cfg) and change EnableUPnP none to EnableUPnP NX (uncomment if it’s commented out). Save the file and restart nxserver (sudo /usr/NX/bin/nxserver --restart). More details about enabling UPnP you can find there:

    Then start again ‘Server Status’ window again to check External IP and Port (that information should show also in the output of the command: sudo /usr/NX/bin/nxserver --upnpstatus).

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.