Problems with keyboard on Mac server

Forum / NoMachine for Mac / Problems with keyboard on Mac server

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #17315

    I’ve been using NoMachine to connect remotely to my Mac from a Windows pc for a while without problems, but recently, the keyboard has stopped working when in a NoMachine session.

    Pressing the “A” key does register, but all other keys I’ve tried do nothing. Opening the keyboard viewer on the mac, I get the same behavior, where clicking on the “A” key registers, all others have no effect. Oddly all keys do work at the login screen on the Mac, and to enter my username and password when I get an elevated prompt, but in the normal user session they do nothing.

    Both the Mac server and Windows client are version 6.0.66. My keyboard works fine when I’m sitting physically at the mac so I think the problem must be related to the NoMachine session running.

    Anyone run into this, or know what might be causing the problem?




    can you please tell us your OSX and NoMachine versions? Is the problem present also when NoMachine is not used?

    As a possible workaround you can try to edit /Applications/ on server side and add this line:

    DisplayServerExtraOptions  "-oldeventapi 1"

    If the problem is still present we would need logs from the OSX side. To gather logs please follow these instructions: (if you are using v. 5) or (for v. 6)
    You can send your logs to forum[at]nomachine[dot]com.


    OSX recently updated to 10.13.2 which I think might coincide with the start of the problem. NoMachine version is 6.0.66 on both client and server.

    The problem is not present when not in a NoMachine session. I’ll try editing the node.cfg tonight when I have access to the computer.


    I realized I could modify the file by logging in through ssh, so I did that and rebooted. Your workaround is working for me. Thank you.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.