Problems with “Match the client resolution upon connecting"

Forum / NoMachine for Linux / Problems with “Match the client resolution upon connecting"

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #20983


    I’m using “Match the client resolution upon connecting” with free version NoMachine for Linux 6.4.6 on CentOS 7 (for both local client and remote “virtual desktop” on cloud) and it randomly does not work.

    With “virtual desktop” I mean that I’m using the NoMachine’s embedded X server, with its capabilities of working with resolution not limited to that of the remote physical desktop.

    I found the problem at least 1 year ago, starting with free version NoMachine 5. It was there also on CentOS 6, and is still there both with GNOME or KDE on local client and/or remote virtual desktop. Always, my local client resolution was 1367×768 and remote cloud server’s physical desktop resolution was 800×600.

    A similar topic of March 2016

    Problems with “Change the server resolution to match the client when I connect”

    was marked as solved after the following post

    “Please update to the latest version. That should fix it.”

    of Keymaster Britgirl.


    It looks related to this problem: Automatic resize fails in GNOME virtual desktops

    Which version of NoMachine are you using?


    I’m using  free version NoMachine for Linux 6.4.6 on both client and server.

    The problem about GNOME virtual desktop was fixed with release  6.1.6 and my problem is there also with KDE desktop.

    The problem is that, when the connection occurs, sometimes the display is set to the correct resolution of 1367×768 and sometimes it is set to the physical resolution 800×600. Never the desktop reverts to another size during normal operation.


    You want to use the embedded X server: in NoMachine free edition a such thing is possible if display service is not running on the remote server.
    So you should ensure you turned off the display service (KDM, GDM, LigthDM or whatever).
    You wrote about a server with “physical resolution 800×600”, but if display service were turned off you’d have no “physical resulution” at all.
    Did you turn off the display service?


    … and, sorry, I say “physical resolution 800×600” because if I run
    systemctl set-default

    so using the standard X server, I get a connection to a physical display 800×600.


    I’m using the embedded X server of NoMachine 6.4.6 free edition for Linux, on CentOS 7 environment.

    On CentOS 7, I run the command

    systemctl get-default

    getting the output

    Of course, to use the embedded X server of NoMachine, I didn’t run systemctl set-default Is that enough or something else is needed to turn off the display service?



    It looks enough, just check if any X server is running with ps -ef | grep X.


    *** I FOUND A SOLUTION ***

    The problem is now clear and REPEATABLE. There is a bug (I think) but there is also a temporary simple solution.

    Very often I use “New connection” from NoMachine menu, because I’m in a testing environment.
    Starting a new connection, a series of intermediate windows are displayed before the final GNOME or KDE desktop.
    At the bottom of each intermediate window “Don’t show this message again for this connection” is displayed on the left and the OK button on the right.
    If I click on the OK button of each intermediate window in rapid sequence, I get a final GNOME or KDE desktop with WRONG display resolution set to 800×600.
    If I wait some seconds, so that when I click on the OK button of the last intermediate window (see ATTACHMENTS) the background of that window is highlighted, then I get a final GNOME or KDE desktop with display resolution correctly set to 1366×768.
    Moreover, the correct display resolution is also set when no intermediate windows are displayed at all, i.e. after “Don’t show this message again for this connection” is flagged for all intermediate windows.

    ATTACHMENTS: last intermediate window with and without highlighted background


    I think the explanation is this.

    KDE stores the size somewhere (.kde/share/config/systemsettingsrc, probably). The saved size is 800×600. After it starts, KDE set the saved size. If NoMachine sets its size after KDE, you get the “right” size, otherwise you get the “wrong” one.

    I don’t think it is a bug, but I’d check whether KDE saves the correct screen size (at Logout or when size is changed through System Settings).

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.