Public key not working

Forum / General Discussions / Public key not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #25880


    I have a Mac running Catalina; dell laptop and desktop running Windows 10, using the physical

    I used ssh-keygen and puttygen to create public and private keys. However, on the Mac, it creates a proper ssh key file but on the PC, it looks totally different, with files starting with —BEGIN SSH2 PUBLIC KEY—.

    I tried adding rsa-ssh at the beginning, and putting each one in the authorized.crt file in the config folder in each account but it refuses to login. It works fine on password authentication however.

    The desktop doesn’t have a password, so NoMachine it won’t work with that, hence public key. Does anyone have any ideas?


    Please follow the article:

    “If you have generated the SSH key pair on Windows, for example by using PuTTYgen, be sure it’s in OpenSSH format or convert it. To do that choose the key file in the PuTTYgen main window. Then go to Conversions->Export OpenSSH key to export your private key and save it.”

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.