Raspberry Pi 3 Questions

Forum / NoMachine for Raspberry Pi / Raspberry Pi 3 Questions

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #18189


    I noticed that there are quite a few ways to install NoMachine onto a Raspberry Pi 3 (ARMv6, ARMv7 or ARMv8).

    I know they are OS dependent. I’ve only ever used different Raspbian versions. Never tried installing Ubuntu or Fedora.

    I am wondering what the “best” way would be? By best, I mean the most resource efficient way. The “snappiest” way.

    There are way too many options to just test them all; so, I figure I’d ask here to see what others’ experiences are.

    At first glance, it seems like using an ARMv8 version would be best, but I have no idea.

    Anyone have any tutorials?

    Also, once it is up and running, are there other considerations to take into account to make it better? Like h264 for example?



    Yes, you are right – installation of NoMachine depends on the OS and it’s efficiency. Useful tips for Raspberry you can find here: https://www.nomachine.com/tips-on-how-to-set-up-your-raspberry-pi-for-remote-access-via-nomachine. We made some tests and it shows that the most efficient OSes on RPi3 with NoMachine on 1080p resolution are Ubuntu Mate 16.04 and Raspbian 9 on armv7 architecture.

    Connection to the physical desktop with 1080p resolution:

    1) Raspbian 9 armv7

    RAM usage for nx* processes: 249 MB
    CPU usage for nx* processes: 23.58%

    2) Ubuntu Mate 16.04 armv7

    RAM usage for nx* processes: 258 MB
    CPU usage for nx* processes: 14.93%

    3) Fedora 26 armv7

    RAM usage for nx* processes: 330 MB
    CPU usage for nx* processes: 25.71%

    4) Debian 8 arm64

    RAM usage for nx* processes: 590 MB
    CPU usage for nx* processes: 59.68%


    About H.264 support. It is available in Enterprise Desktop for Raspberry, that means you get server-side encoding included. It was mentioned in post: https://forums.nomachine.com/topic/hardware-h264-decodeencode-support-in-rpi23.


    Hi…I am a new user here. I have a Raspberry Pi 3, running Stretch and I am trying to setup a USB driver for a motor controller. I’m trying to follow the instructions for setting up the driver, but I am running into the below issues when I try to execute the following command.


    Hi, this might be better to ask in a new topic if it’s about USB support on Raspberry. Can you paste what the issues are and what command you are executing? I can then move your question to a new thread. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.