Reconnecting virtual session – VP8 codec instead of lightweight

Forum / NoMachine for Linux / Reconnecting virtual session – VP8 codec instead of lightweight

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #4428

    When I connect to my NoMachine server from my client on a virtual KDE/Gnome display, I can see that I am using the “lightweight” mode for my display output (as viewed from the client display menu).  If I then disconnect from the session and later reconnect, I see it is using “codec VP8” instead.

    I first noticed this by the very sluggish redraws after reconnecting to a session.  I found I have to check the box for “Disable mulit-pass display encoding” when using VP8 to ensure the window refreshes look right.

    The NX server is running v4.2.21 on Linux, and I am connecting from Mac OSX running v4.2.26.

    Is there anything that can be done to ensure lightweight mode is used when reconnecting to an existing session?


    We cannot reproduce the described behaviour in our labs with current version (4.2.27).

    Is upgrading a option for you?

    In case you will still experience this issue, please collect logs as explained in and send them to forum[at]nomachine[dot]com.


    Thanks for the response on this.  I can ask our IT staff to upgrade on the server-side, but it’s unlikely to happen soon.  I’ll gather the logs, and see if my local IT support can assist further with troubleshooting/upgrading.

    Is there anything in any of the logs that might clue me into the issue?

    The server is running CentOS 6.5 (Final) — in case that makes any difference.


    My local IT staff performed the upgrade to 4.2.27 on the Linux (CentOS) VM to which I connect.  This had no affect on the issue as stated above.  Upon reconnecting to an existing Virtual Desktop, the client uses the VP8 codec instead of lightweight.  I’ll gather the required logs and send them as requested.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.