Redirecting a scanner from Raspberry Pi3 to Windows 7

Forum / NoMachine for Raspberry Pi / Redirecting a scanner from Raspberry Pi3 to Windows 7

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #16346

    Hello there!

    I just discovered NoMachine and am fairly impressed with what it seems to feature. What I can not yet accomplish is the following scenario:

    – I have a Raspberry Pi 3 and installed NoMachine v5.3.12

    – I want to connect to a Windows 7 x64 Pro machine

    – to the Raspberry Pi 3 is a Canon LiDE 60 Scanner attached

    When I connect to the Windows machine I can not see the scanner unter the local or remote devices. Do I need to install some drivers on the Raspi or something? I thought about maybe it being a permission issue so I ran nxplayer as root via “gksu /usr/NX/bin/nxplayer” but still no scanner available.


    Regards Sebastian


    Dear Sebastian,

    If your Canon LiDE 60 Scanner is visible on your RPI 3 as a common USB device, it can be forwarded with help of USB forwarding that will be available in RPI packages in version 6.0 – coming soon.

    Best Regards,


    Hello Giogi!

    Thank you for your response. The Version 6.0.62 brought the update and I can see the FR here:

    Now in the client I have the devices listed. When I try to connect them they are showing a loading spinner and later a red exclamation mark.

    I gathered the logs and looked through them but can not find whats going on. Maybe I need to unblock certain ports in the firewall?

    Additional info:

    server is Windows 7 x64 Professional running NoMachine 6.0.62-5

    client is Raspberry Pi 3 Debian stretch running NoMachine 6.0.62-10


    Regards Sebastian



    We make tests on our machines with printer\scanner sharing and it works very well.

    For now we can suggest to try few things:

    1. Completely uninstall NM from both machines.

    2. Install latest NM version on both machines NoMachine 6.0.66

    3. Try to share any another USB device i.e. USB flash drive.

    Also please provide us some info about kernel version on Raspberry Pi.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.