Remote access via IP: Timeout

Forum / NoMachine for Linux / Remote access via IP: Timeout

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #45884

    Hi, I’m trying to setup my Linux laptop to be accessed by smartphone and PC from anywhere in the world. Steps I’ve taken:
    1. Enabling PNP UDP on the server

    2. Enabling PNP UDP on my router (as far as I can tell it worked)

    3. No luck with that so port forwarded 4000 to the local IP of the server.

    That’s about it. Other posts’ answers unfortunately didn’t help so I hope anyone of you has an idea for me.

    Port forward:
    “IPv4-tcp, udp

    From any host in WAN
    Via any router IP at port 4000”


    “IP, port 4000 in any zone”

    Local IP is definitely correct, getting global IP just from
    Local access via local IP works nice, but without being in my own LAN I cannot access it and get a timeout.


    NoMachine free version

    Android/Windows 11 access to Ubuntu LTS


    Hi KeyX,
    to make UPnP work UPnP you need two things.
    1) Router that supports UPnP
    2) Public IP address. You can’t be behind double NAT

    If you have the set key  – EnableUPnP NXUDP in server.cfg
    Run these commands in the console
/usr/NX/bin/nxserver –restart
    sudo /etc/NX/nxserver –upnpmap
    The first one will restart the server NoMachine
    The second one will show whether you have set the UPnP port on the router.
    You should see something like this: 
NX UDP port 4000 mapped to: Your_Public_IP:23167

    Example port 23167 is the port you should connect to your public IP.


Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.