Reset config to new/default

Forum / NoMachine for Linux / Reset config to new/default

  • This topic has 2 replies, 2 voices, and was last updated 1 month ago by nb.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #47363
    nb
    Participant

    Hi,

    I’ve been  having a heck of a time with NoMachine.  It’s incredibly slow across gigabit wired ethernet.  Maybe I made a mistake with the configuration (I’ve been trying lots of combinations of settings to make it more performant).

    Is there a way to reset all NoMachine server settings back to default?  Like when it was first installed?

    A little about my system:

    • Debian 12.5
    • KDE 5.27, X11 (not Wayland)
    • HP Elitedesk 800 G5, Intel i5-8500, built in graphics, 128GB RAM, 2TB Samsung 980 Pro SSD
    • I need screen my screen blanked/locked when accessing remotely, because security.
    • Same problem(s) when connecting with NoMachine client on Windows or Linux.
    #47395
    Britgirl
    Keymaster

    Hi,

    the quickest way to reset your NoMachine server settings is to uninstall and reinstall.

    Regarding the issue about slowness, one thing you can check is that the monitor is actually turned when connecting. We have seen cases in the past on Linux where the video drivers were limiting the frame rate to 1 fps in the case the monitor was detached or turned off. Session statistics would also be useful. You can get these during the session.

    – run the menu panel within the session by Ctrl+Alt+0 or click on the page peel
    – click on Connection
    – then click on ‘Take the statistics’ and save them on your local device.

    You can attach them here.

    #47445
    nb
    Participant

    video drivers were limiting the frame rate to 1 fps in the case the monitor was detached or turned off

    That did the trick but it’s more of a work-around than a solution.  It’s fairly inconvenient as it requires that I leave the monitor on and the KVM switch attached to that system.  Maybe that is something that won’t be a problem when Wayland is fully supported.

    Thanks for your response.

    -nb

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.