Screen resolution problem with El Capitan

Forum / NoMachine for Mac / Screen resolution problem with El Capitan

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #8464

    I have a MacBook Pro (MBP) and a headless Mac Mini (MM), using NoMachine to control the MM from the MBP.  I updated to NoMachine 5.0.43 yesterday under Yosemite.  Today I upgraded the OS on my headless Mac Mini to El Capitan.  Previously NoMachine has been delivering the full widescreen desktop view of my MM, scaled to the display of the MBP.  After the El Capitan update it now delivers a horizontally compressed (i.e. distorted) 4:3 desktop, and worse, I get 2 mouse pointers.  One pointer follows the whole screen and the other a reduced-scale version of the screen, with both pointers converging at the top left.  The further away from the top left, the greater the separation between the pointers.  The active pointer (the one that responds to the mouse clicks) is the one that doesn’t follow the whole screen, so that I am effectively screwed.

    NoMachine had previously been working very well for me.  Help!


    What you descibe may happen if NoMachine is not able to get the current screen resolution from the system. In the past various glitches have been observed on headless Mac machines, not entirely due to NoMachine, so I would check if a reboot or a restart of NoMachine services solve the problem.

    We’ve tried to reproduce this issue in our labs, without success. If you are willing to help us with investigations, please contact us at forum[at]nomachine[dot]comand we will be glad to send you a debug library.


    Thanks, fra81.  I followed your instructions and it appears to have worked.  This is surprising since I had in fact rebooted the Mac Mini several times in an attempt to clear the problem but it has persisted.  This time I attempted to quit NoMachine before rebooting.  Unfortunately it seems there is no obvious way to do that!  I ended up going into Activity Monitor and force-quitting every process that began with nx….  Having done this, nxnode.bin refused to go away.  At that point I rebooted the Mac Mini and when it came back to life NoMachine was working normally.  I have no idea if any of that made any sense to you, but that’s how it was.


    A more comfortable way to shutdown the server: NoMachine tray icon => Show the server status => Use the ON/OFF button.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.