Segfault in nxupnp

Forum / NoMachine for Linux / Segfault in nxupnp

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #216

    Hi Gang,

    When I run NX NXSERVER-4.0.346 on Linux Mint 15 (Ubuntu 13.04) on an AMD64 platform with 8GBs of RAM and NVidia NVS 5200 graphics I see a lot of these:

    [25997.289545] nxupnp[24000]: segfault at 0 ip 000000000040c0e8 sp 00007fff006a6030 error 4 in nxupnp[400000+10000]
    [26027.391104] nxupnp[24015]: segfault at 0 ip 000000000040c0e8 sp 00007fff7e78f020 error 4 in nxupnp[400000+10000]
    [26057.503555] nxupnp[24050]: segfault at 0 ip 000000000040c0e8 sp 00007fff39fea680 error 4 in nxupnp[400000+10000]
    [26087.611854] nxupnp[24068]: segfault at 0 ip 000000000040c0e8 sp 00007fff23bf7050 error 4 in nxupnp[400000+10000]

    Anyone have any idea how to either fix these or at least shut the service off?



    I am seeing exactly the same problem on 64-bit Fedora 19 system with Intel -7-4770 CPU and NVIDIA GK107 [NVS510]

    Running the client causes a hard lock of the system within a couple of minutes of running the client software.


    OK, it’s good to know that I’m not the only one to see this.


    The best is if you can enable debug log level into server.cfg (uncomment and set SessionLogLevel 7) .

    Then restart the server with: /usr/NX/bin/nxserver –restart

    and copy here nxserver.log if it’s not too long or send it to support.


    Here is a copy of the server.log file with debugging enabled as was suggested. Hopefully, one of the developers can make heads or tails of this. There appears to be a lot of debug info that will need to be sorted through to try and find why this process is segfaulting.


    OK, so it won’t allow me to upload the server log file. I’ll try it again in compressed format.


    I don’t think the server log is going to tell anything useful. If it’s a nxupnp crash, only a core file with symbols will help. If you get in contact with the support, we’ll provide such binary tomorrow.

    In the meanwhile you can just replace the binary with a script doing nothing:

    > sudo sh
    > /usr/NX/bin/nxserver –shutdown
    > cd /usr/NX/bin/
    > mv nxupnp nxpupnp.ori
    > cat > nxupnp
    sleep 1
    exit 0
    ^D <— press CTRL+D here
    > chmod a+x nxupnp

    Test it:

    > ./nxupnp

    Restart the server:

    /usr/NX/bin/nxserver –startup

    I tried it and I was still able to connect. UPnP is only used to query and forward ports on the router. You won’t have ports forwarded but, except for that, it should work fine.

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.