Select Wifi’s IP over Ethernet’s IP

Forum / NoMachine for Linux / Select Wifi’s IP over Ethernet’s IP

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #43208

    Hello guys,

    I am trying to use NoMachine to mirror my PC to a tablet, both OS Ubuntu 18.04.06 LTS. I tried to connect two devices through WiFi and its working perfect! Although when I plug-in an ethernet cable, then the connection gets lost! The ethernet is used to transfer data from a lidar (measure device) to PC. NoMachine, maybe, gives priority to the ethernet? So, the tablet trying to connect to ethernet’s IP,  even if it detects PC on local-network (same WiFi) and even if I gave the PC’s host. Both ethernet and WiFi using the same port:4000 but ethernet has priority.

    IP list which provides by NoMachine is the the following:





    Could you help me to solve this problem?

    Thanks in advance.


    Is there any way to fix this through server.cfg or node.cfg ?


    Hi Manchris,
    I will summarize what I know about your problem. If I have misunderstood, let me know.

    You have two devices: a tablet (NoMachine client) and a computer (NoMachine server).
    When both devices are connected to WiFi, the connection from the NoMachine client to the NoMachine server works fine.
    When you connect a cable to the network card in the computer, you cannot connect from the tablet to the computer.Or do you want to connect via WiFi because lidar transmits data via ethernet cable.

    Which of these statements above is true?

    What does “if I gave the PC’s host” mean. are you specifying the hostname e.g. UbuntuTom?
    Are you specifying the NoMachine Server’s WiFi IP in the NoMachine client?
    What type of connection is IP with X at the end and which with Y at the end?

    NoMachine uses interface priorities set in your system, it will not set them itself.



    Hello Tom and thanks for the help.

    You are correct.

    When I don’t have connect the Ethernet cable in the computer, NoMachine works fine!!

    My IP list, which NoMachine shows me, is the following:(for example)



    but when I connect Ethernet (which provide ONLY data from LIDAR to pc) then my IP list is:

    nx:// (Ethernet IP)

    ssh:// (Ethernet IP)

    nx:// (Wi-Fi IP)

    ssh:// (Wi-Fi IP)

    and I can’t connect from tablet to pc even if I try both of IPs. I think this thing happens because they use both the same port (default:4000) and Ethernet has priority over Wi-Fi.

    When I said “if I gave the PC’s host” I meant that I filled the host blank box with Wi-Fi’s IP (, port:4000 and protocol:nx, following the instrustions.

    Is there any way to make NoMachine give priority to Wi-Fi over Ethernet ? Or make NoMachine “don’t see” Ethernet ports, because in general I want Ethernet, as it provides measurement data to pc from LIDAR.


    I uncheck the ‘ethernet ports’ option from NoMachine App Settings, but the app still recognizes when I plug in an Ethernet cable.

    Thanks again for the help.






    i have tried solutions like this post, but, still i have the same problem!!


    I did an experiment in my lab. I checked the possibility of connecting to my laptop with Ubuntu 22.04 and NoMachine free 8.4.2.
    Regardless of whether the network cable is connected, I can connect to it via NoMachine via the WiFi interface.

    What version of NoMachine are you using?
    You can run the netstat -lntu | command grep 4000 and paste its result?

    You can try using the options in server.cfg
    # Specify the network interface where the NX service will be bound.
    # Populate the field with an IP address or a domain name.
    # NXdListenAddress “”
    This option will force nxd listening on a specific IP address.
    But if the IP address is assigned dynamically and changes from time to time, it will require changes in the cfg file.



    Hi Tom,

    1) my NoMachine version is 8.4.2

    2) netstat -lntu | command grep 4000
    tcp        0      0  *               LISTEN
    tcp6       0      0 :::4000                        :::*                    LISTEN
    udp        0      0*
    udp6       0      0 :::4000                       :::*

    3) I tried to change NXdListenAddress to my  WiFi’s adress but still not working.



    Could you show me which settings did you choose from the app, so you connected to Wi-Fi and not to the Ethernet ?


    Hi Manchys,
    when computer has two interfaces connected, each of them has a different IP address.
    I just connect to the IP of the WiFi interface.

    You can display the addresses with the command “ip a” in the console but you wrote that WiFi has IP (I don’t know if it’s an example). Enter this IP in the NoMachine Client.

    Below you can see the manual on how to add a connection in NoMachine.



    I’m having the same problem here. Been trying for a while to get this to work.

    I have a Jetson Nano with the same problem. Separate Ethernet and Wifi NIC’s. If I only have one or the other connected, NoMachine works fine, but if both are connected, I can’t connect to it anymore and port forwarding to one of the two IP’s stops working as well.


    Hello Tom,

    yeah wifi’s IP was en example. I’m attaching here some printscreens from the server(pc) and tablet(client)

    ethernet’s ip :

    wifi’s ip:

    I have read the manual and tried this from the first time but still when i connect ethernet I can’t connect to the Wifi’s IP.


    There’s no firewall problem

    geo@geo:~$ sudo ufw status
    Status: inactive

    Thanks again for the help my friend.


    Hi Steveatsws,

    I installed NoMachine Free
 on my Jetson Ubuntu 20.04.
    I have Nvidia Jetson Nano – ARM Cortex A57 4x 1,43 GHz, Nvidia Maxwell
Because it has one built-in card, I installed the second LAN via USB.

    I did a test, connected both cards to ethernet cables. I connected from the NoMachine client to the server, first to the IP address of the first card, I disconnected NoMachine client,  then I connected to the IP of the second card. Everything worked.
    I disconnected the network cables in the second card and connected to the IP of the first card. Everything was still working.

    I don’t know what could be causing your problems. Perhaps the NoMachine logs will help.
    Please read the article:

    Collect logs and upload them.

    P.S. I saw you opened another thread on the forum, maybe we can move the Jetson discussion there?



    Hi Manchys,
    Just to be sure, I set up NoMachine on a VM with Ubuntu 18.04 and two NICs. I had no problems like you.

    Please prepare NoMachine logs according to the article:

    At the beginning, we will only need logs from the server.

    Start with the situation where you are connected to the NoMachine server via WiFi, disconnect the NoMachine client, connect the ethernet cable, wait two minutes, and try connecting via WiFi again.



    No logs were received. For this reason the topic is now closed. Please open a new topic if you continue to encounter the same issue, but without logs we will not be able to investigate.

Viewing 14 posts - 1 through 14 (of 14 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.