Selection using mouse disappears

Forum / NoMachine for Windows / Selection using mouse disappears

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2141

    I recently upgraded from an earlier version of NoMachine, and I’m very disappointed. In many ways, the newest version seems inferior to the older version. The older version had a much clunkier-looking user interface, but it seemed to work better.

    The specific problem with the new version is very mysterious and annoying. I use NoMachine to get a remote Linux desktop from my Windows computer. When I do editing (I use the program gedit on the remote Linux machine), the mouse no longer works reliably for selecting chunks of text for cut and paste. If I try to select an entire paragraph, the selection breaks, so that I only get a few words of the paragraph. This is very frustrating. And, as I say, mysterious. It never happened with the older version of NoMachine.

    Also, I’ve tried other Linux editors (emacs, for example), and I don’t have the problem with them. So that is another aspect of the mystery. Whatever change was made in NoMachine, it seems strange that it only affects mouse selection for one program, and not another. Any ideas from anyone?


    It would be useful to understand how you feel the new version is inferior to the older version, so that we can improve it.

    The biggest change in version 4 is that you can do all the configuration you did in the old client during the session, while in version 3 you had to take a number of decisions before connecting to the remote server and, once connected, you could do very little. The initial GUI, by which you must choose the computer to connect to, is designed to be “dynamic”.

    As for the select text issue, it would help to know what Windows version on the client you have installed, what Linux distribution and version you are using on the server side, what DE it is. What NoMachine products and version have you installed on client and server sides?  (see list below “What to include”). We assume that you have Workstation installed on the server side.

    We are aware of a problem with selecting text for which a TR is open


    This is an extremely annoying problem and we are working at it, trying to solve it before the 4.1 release. In fact this is one of the bugs that we definitely wanted to get resolved at the cost of holding the release back. Since we are going to release on Wednesday, there is not much time remained.

    Unfortunately the problem is not trivial. If you are interested in the challenges we have to face trying to make the clipboard work in NX, I suggest you give a look at this document, especially the part that says “It’s nearly impossible to make the clipboard shared between different desktop computers. In fact it is possible, but such an implementation would be needlessly difficult and complex”. Making the clipboard shared between different desktop computers is exactly what NX needs to do.

    Add to this that 4 different X applications are likely to use the clipboard is 4 different ways and you get a picture of the situation. The reason the clipboard worked “better” in the 3 is that it was subject to many limitations. We worked hard to lift most of these limitations, but this obviously introduced new problems.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.