Sending Control characters not working

Forum / NoMachine for Linux / Sending Control characters not working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #46117
    OldMan
    Participant

    So, I have NoMachine setup on my laptop and the system in my cellar, both are running Linux Mint. When I connect to the console of the machine in the cellar and run nano from a terminal window, I’m stuck!  Trying to enter any “ctrl-<key>” combination enter’s JUST the character!

    Both machines are running free NoMachine version 8.10.1. on Linux Mint 21.2 with Cinnamon 5.8.4.

    I’ve configured my laptop with the “Grab the keyboard input” checked.  See the attached file.

    Not sure what other information is needed, so ask! 😉

    Thanks

    Don

    #46171
    fra81
    Moderator

    Hi OldMan,

    can you try to run the ‘xev’ utility in the remote desktop, send the Ctrl key to it through the NoMachine remote session and show us what is reported in the output? I would start with sending any other key first, just to check if everything is set up correctly and the keys are reported in the output. Then you can type just the Ctrl key, to see if it is sent through. Finally, you can try with the problematic Ctrl-<key> combinations and show us the xev output.

    #46174
    OldMan
    Participant

    I managed to get it working. I had the “show where your mouse cursor is when you hit the control key” option enabled. Once I unchecked that, <ctrl-x> and all the others started working on the client machine.

    Curiously enough, while the control characters are working on the remote systems, when I’m not in one of the remote windows, <control>, by itself, still shows me where the cursor is!

    I ran xev on the client machine and included the results in the “keys.txt” attached file. If my memory is working I typed “aA<ctrl-x><ctrl>” not sure what others.

    Thanks for looking at this!

    Don

    #46187
    Britgirl
    Participant

    Hi, your attachment didn’t attach. Can you submit any attachments to forum[at]nomachine[dot]com? Thanks!

    #46193
    OldMan
    Participant

    Not sure what to make of your response, Britgirl, but I emailed the file as an attachment to the specified email address with the number (#46174) of the post it should be attached to.

    To the web devs of the forum:

    I’m a bit curious as to why the option to upload files is displayed if the person uploading isn’t allowed to upload files. If it’s the type that’s not allowed, though why .txt files would not be all allowed confuses me, then what file types are allowed (or not allowed, whichever list is shorter), should be clearly specified and/or a check done upon upload and a message displayed indicating the file type is invalid.

    I hope the requested info is useful, though, at this point, I’m all set.

    Thanks for taking the time to look into this!

    Don

     

    #46196
    Britgirl
    Participant

    Not sure what to make of your response, Britgirl, but I emailed the file as an attachment to the specified email address with the number (#46174) of the post it should be attached to.

    I was referring to your attachment which didn’t attach 🙂
    You previously wrote ” I ran xev on the client machine and included the results in the “keys.txt” attached file.” and it wasn’t attached.  So I asked for you to send it. But you’re all set now anyway.

    About your comment on attachments, we’ll make a point of adding what types of attachment are permitted so that users know. Right now only the size is stated. That said, some attachments don’t pass the spam filter because of unusual characters within. We’ll get this checked out. Thanks again for your feedback.

    Happy nomachining!

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.