Server doesn’t start on Windows 10

Forum / NoMachine for Windows / Server doesn’t start on Windows 10

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #25896

    I’m looking at NoMachine as a replacement for Remote Desktop due to the latter’s serious issues since winver 1903. Anyone that needs OpenGL on a remote machine is likely similarly searching for a replacement.

    I was able to set up a VMware linux box and connect from Windows to Ubuntu without problem. However, I cannot get the Windows machine to function as a NoMachine server. After several tries, to simplify any confounding issues, I created a clean bare VMware Windows 10 installation (winver 1909) with nothing else on it, and still get the same results: the NoMachine server immediately stops every time you start it.

    I installed NoMachine v6.9.2 (just downloaded from the site), rebooted, and NoMachine showed “server stopped” when I opened the application. When I try to start the server, it momentarily turns green in the NoMachine window, then immediately stops and shows yellow again.

    I changed the VM Window’s machine name to remove the default hyphen in it, in case any non-alpha characters there caused the issue, but this did not fix it.

    Attached are the log files.

    Based off another forum topic, I checked on pipe names, with these results:


    Please assist. Thank you.



    From the logs you provided the reason seems to be here:

    2020-03-10 13:03:06 012.355  8568 NXSERVER WARNING! Process 'c:\apps\nomachine\\bin\\nxexec --server --upnpstatus' with pid '9152/812' finished with exit code 1 after 0,015 seconds.
    9152 1328 13:03:06 012 nxexecExecServer: ERROR! Only nxnode or nxserver can run --server command.
    9152 1328 13:03:06 012 nxexecExecServer: ERROR! Cannot execute nxserver process.
    Error code is : 0.^M
    9152 1328 13:03:06 012 main: ERROR! Error: Server exec failed.

    This is a bit of a puzzler, the path c:\apps\nomachine\\bin\\nxexec clearly exist, it is
    clearly executed by nxserver, but the nxecec cannot recognize it.

    The problem could be a result of bad installation, did you choose c:\apps\nomachine during the installation, or it was copied afterwards?

    There is also a file ‘c:\ProgramData\NoMachine\nxserver\localhost\server.cfg’,
    could you confirm that in this file a key “ServerRoot” is set up to point to the installation directory?



    Thank you, Mth! That was what the trouble was!

    Yes, I did specify the alternate installation path during installation, and the server.cfg file did have the ServerRoot key pointed to c:\apps\nomachine .

    However, I had a friend years ago that recommended to always install apps to their preferred paths to avoid trouble. So I uninstalled NoMachine, then reinstalled it, allowing it to install to it’s preferred path.

    Bingo! That fixed the trouble.

    The NoMachine team may want to still check the installation procedures — a clean NoMachine install (to a non-standard path) on a clean Win10 (winver 1909) machine should reproduce the problem for them to study if desired.

    Meanwhile, I’m able to go happily forward. Thank you again! You rock!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.