Server not fully starting, can’t connect

Forum / NoMachine for Linux / Server not fully starting, can’t connect

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #13515

    I am installing NoMachine on ubuntu 16.04. I can’t connect to it from my other system on the same router. The server log shows:

    Info: Slave server running with pid 17183.
    Info: Listening to slave connections on port 25001.
    17173 17173 16:55:56 732.323 UiUtility: Converting system language en_CA to supported standard.
    Info: Starting NoMachine Monitor version ‘5.1.62’.
    Info: Loaded translation files for ‘English’.
    17173 17173 16:55:56 746.445 OsDetect: Setting os type to ‘Ubuntu’.
    17173 17173 16:55:56 746.543 Main: Creating a new connection monitor.
    17173 17173 16:55:57 143.594 ClientThread: Creating new thread.
    /usr/NX/lib/ version `GLIBCXX_3.4.20′ not found (required by /usr/lib/x86_64-linux-gnu/
    Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/
    17173 17173 16:55:57 289.192 MonitorService: Enabled drag and drop feature.

    I have done an upgrade and dist-upgrade, same issue.

    What can I do to fix this?


    We aren’t able to reproduce it, so need to ask you for logs from both sides, client and server. Follow the instructions here, making sure you reproduce the error once you’ve enabled debug on the server side. Send them as attachments to forum [at] nomachine [dot] com.


    I sent the info. I had tried again after doing a substantial apt update, and I believe the symptoms have changed, but I still can’t connect. I forwarded you the logs.


    Looks like you are trying to connect by SSH protocol to the port 4000.
    To fix this you can create a new connection in nxplayer and use
    default settings or you can change your current connection:

    1. Open nxplayer and find icon of your current connection.

    2. Click right mouse button on the connection.

    3. From a context menu choose ‘Edit connection’.

    4. In ‘Protocol’ field choose NX.

    5. In ‘Port’ field set 4000.

    6. Accept your changes by clicking ‘OK’ button.

    After the fix if you still have problem, please try connect again.
    Wait until error shows up in nxplayer and then click ‘Save logs’
    button. Please save and send the log file to us.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.