Session closes when connecting to Elementary OS

Forum / NoMachine for Linux / Session closes when connecting to Elementary OS

  • This topic has 3 replies, 2 voices, and was last updated 7 years ago by kroy.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13705
    efkan
    Participant

    Actually I encountered this issue several times before. Finally I found how to reproduce this error.

    The bug re-producing steps on Elementary OS Loki:

    1. Open NoMachine application.

    2. The app should be opened normal window size. Then grab the from its title bar and hit the top of the screen by dragging for to maximize the app window.

    3. Click onto a found NoMachine server to connect it and voila! My session is closed. After logging-in I would see that the all opened application was closed. The all of my works..

    Fortunately I could find the bug reproducing. After this I ever and never try to maximize and then connect to my desktop computer.

    I’ve added the syslog lines as an attachment.

    To get relevant log lines, first I’ve opened and maximized the app window by dragging and hitting then cleared the syslog file and then click onto the my founded NoMachine server-that is my linux desktop.

    After I was thrown, I waited 10 second without a touch to my laptop to find the relevant part of syslog thanks to log writing time.

    I hope this helps.

    #13716
    kroy
    Contributor

    We couldn’t reproduce such issue on our Elementary OS Loki. Can you send client logs (it’s in ~/.nx directory, more about gathering NoMachine logs: https://www.nomachine.com/DT07M00098#5) to forum[at]nomachine[dot]com? Is there any core generated when problem shows (in default core files shows in /var/crash or $HOME directory)? If there is please send also backtrace.

    #13718
    efkan
    Participant

    After I post my entry I’ve tried to restart both of two computer and try again. Unfortunately I couldn’t reproduce the issue too.

    I’ve attached nx logs which are related with my yesterday experiences. Also I will send it forum[at]nomachine[dot]com address.

    Now, there is no core generated backtrace.

     

    Attachments:
    #13721
    kroy
    Contributor

    It looks like a crash of Xorg. Please check if there are software updates available for your system. If not, you look for Xorg.0.log to see the stack and verify if the problem is known on Elementary OS bug lists.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.