Session negotiation failed: Cannot connect to the requested session

Forum / NoMachine for Linux / Session negotiation failed: Cannot connect to the requested session

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #31465

    Cross-posted from the Windows forum, as I think the problem is on the Linux side. I’m trying to connect from Windows 10 to Linux Redhat 7 (physical display). I am receiving the error “Session negotiation failed: Cannot connect to the requested session.”

    Windows version: 7.0.211 (NoMachine “free” version)

    Linux server version: 6.12.3

    Linux Desktop: Gnome


    I saved the connection, session, and settings log files. Not sure which is relevant to send. On the Linux side the nxerror.log says “The remote application terminated unexpectedly.” I’ve checked the DefaultDesktopCommand and it looks ok, as other displays I’ve connected to are using the same.


    It’s difficult to say without seeing server-side logs. Please follow the instructions in this article and submit everything to forum[at]nomachine[dot]com.


    The instructions provided are not very helpful. I am confused as to what path I should be using when creating the tar file. What directory should I be in when running the command? I only have an .nx directory under my local /home directory. I keep getting an error saying “gzip: nxdir.tar.gz: No such file”.


    It was easier for me to cd to the log directory and tar the entire log directory. I have sent the file, hopefully it contains the server log.



    The problem here is that nxnode process we start to run the session dies with signal 11.

    29393 29393 2021-01-22 18:06:21 322.548 NXSERVER WARNING! Process '/usr/NX/bin/nxexec --node --user katherine.dadamo --priority realtime --mode 0 --pid 29 -H 4' with pid '29987/29987' finished with exit code 11 after 1,490 seconds.

    Please check if there are any crash reports regarding ‘nxnode’ process, we would be interested in
    seeing the backtrace.

    Also it seems that in node.cfg there is a key set: EnableSyslogSupport = ‘1’
    It means that nxnode process logs will go to system logs instead of NoMachine logs.

    Please grep the system logs file by keyword “NXNODE” and send us the results alongside the
    backtrace from crash report if it exist.

    If You have problems with crash report, please use the following article:



    I edited the sysctl.conf but it did not generate a core file. I also searched the syslog file and did not find any instances of nx. Instead, I ran the recommended command to extract system files:

    journalctl -b -0 | grep -i "nxserver\|nxnode\|nxwebplayer" > journalctl.extract

    I have sent that file. Hopefully it contains more relevant information.


    It’s actually working now. Apparently X was down and that solved the issue.



    Sorry for a bit of confusion, indeed there was no running Xserver, but since you mentioned the DefaultDesktopCommand key I was certain that this is intended and what you need is to make the “desktop on demand” to work.

    This is what was happening:

    1. NoMachine was detecting no Xserver running.
    2. After connecting to the server NoMachine tried to run “desktop on demand”
    3. The desktop on demand was failing because of nxnode process crash.

    Desktop on demand is basically a virtual session started by NoMachine in case there is no physical Xserver running, so fixing lack of Xserver would fix it, if it is the only problem.

    To summarize, if this is enough for you to make this work, it’s OK, but please remember there is some more serious problem there with starting virtual session, so please let us know if you need assistance with debugging this issue.


Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.