Session Negotiation Failed/Cannot create a new display

Forum / NoMachine for Linux / Session Negotiation Failed/Cannot create a new display

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #29291

    Greetings.  Running latest version of NM free-version such that “host” is a Linux box and “client” are Win 10 laptops.

    On the client side we are encountering “The session negotiation failed”  “Error: Cannot create a new display, please contact your system administrator”.

    We have researched on line and made a number of modifications based on similar issues but are still coming up empty.

    We also reviewed the logs on both the Host and Client side, but are not familiar enough with the application to recognize which errors are root-cause vs collateral.

    We apologize for not being able to figure this out on our own and are looking for advice on next steps.

    Here are the details for trouble shooting with logs attached.

    Host – running NM 6.11.2

    Headless remote linux server running RHEL 6.10 (for purposes of security we will call it SERVERa)

    The command     which gnome-session       returns    /usr/bin/gnome-session

    The command     ls /usr/share/xsessions/  returns  gnome.desktop

    The command     locate gnome.session      returns nothing (there is file gnome.session on the system although we are not sure its needed since the system is headless)

    The command     locate Xsession   returns   /etc/X11/xinit/Xsession

    Modified /usr/NX/etc/node.cfg to define DefaultDesktopCommand as  “/etc/X11/xinit/Xsession ‘gnome-session –session=gnome'”

    Deleted old logs with  /bin/rm /usr/NX/var/log/*.log

    Restarted nxserver with      /usr/NX/bin/nxserver –restart    and received the following

    NX> 162 Disabled service: nxserver.

    NX> 162 Service: nxnode already disabled.

    NX> 162 Disabled service: nxd.

    NX> 111 New connections to NoMachine server are enabled.

    NX> 161 Enabled service: nxserver.

    NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.

    NX> 161 Enabled service: nxd.

    Client – running 6.11.2

    Win 10 laptop

    From the NM interface, we have one session saved as “Connection to SERVERa” with the following settings:   Host set to SERVERa, Port set to 4000, Protocol set to NX, Proxy set to No, UDP is 4315

    From the NM interface, we note the “Settings” button and from that new window that appears, we click Server Preferences and note the server on the client side is “Stopped”.  We then click Done to get back to the main window.

    At about 1035am local time when we double click the “Connection to SERVERa” session, the proper username is autopopulated, but after entering the proper password we obtain the result “The session negotiation failed”  “Error: Cannot create a new display, please contact your system administrator”


    After we’ve completed the above steps in the exact sequence as they are listed we captured the logs from both the Host and Client and have them attached.   All client logs (“connection”, “session”, “settings”) are in one attachment, and all host logs (“nxd.log”, “nxerror.log”, “nxserver.log”) are in the other attachment.


    there is an article about that kind of problem:
    How to solve ‘session negotiation failed, application terminated prematurely’

    If you’re still having issues, install ‘xterm’ and run it as desktop command (instead of gnome-session).
    Then from such xterm try to run your environment command, and you should see errors or warnimg.



    Brotech – thank you.   Followed the article you linked,  opened an xterm window and from my $HOME dir typed the command for what I had entered in /usr/NX/etc/node.cfg file  for the DefaultDesktopCommand line  (which is /etc/X11/xinit/Xsession ‘gnome-session –session=gnome’) and nothing happened.  After reading further down in the link you sent I saw that $HOME/.xsessions-error contained info as to why the desktop wasn’t launched.  Turns out the “–session=gnome” is not a valid option.  So just typing in the xterm window   /etc/X11/xinit/Xsession/gnome-session launched the desktop.   I modified /usr/NX/etc/node.cfg.  Did not restart the nxserver.  Then on the client side (win 10 laptop) relaunched a connection and it worked properly.  So thank you very very much.  This worked.

    Moderator you can mark this as solved.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.