Session type unix-xsession-default is not available on node

Forum / NoMachine Terminal Server Products / Session type unix-xsession-default is not available on node

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #44471


    My multi-node setup was working perfectly until now. I relocated the ETS (this is a physical server on linux Centos) to different desk in the server room at my work place and started the server. I can connect to ETS via nomachine but then when I click ‘create new desktop’, I get the error ‘Session negotiation failed.  Error. Cannot start the requested session type on any of the available nodes’.

    And I see this error in the nxserver log:

    NXSERVER ERROR! Session type unix-xsession-default is not available on node nnn.nnn.nnn.nnn:4000.

    I am sure this session type is available and enabled.

    My node.cfg has this:

    DefaultDesktopCommand “/bin/dbus-launch –exit-with-session gnome-session –session=gnome”

    DefaultDesktopCommand “/etc/gdm/Xsession ‘mate-session'”

    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-gnome,unix-xdm

    My server.cfg has this:

    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-gnome,unix-kde,unix-xdm

    I verified with the resourcelist command. I updated the node and restarted nxserver

    /etc/NX/nxserver –resourcelist –class session

    sudo /usr/NX/bin/nxserver –nodeupdate <nodename>

    However the error is not going away. Your help is very much appreciated. Please can you help figure out



    Siva P



    I tried to understand the problem and only case that I could think about is that key unix-xsession-default is removed, or not present in the server.cfg or node.cfg on the node where you want to run session.

    You can verify it by checking configuration files on the node by following command: grep ^AvailableSessionTypes /usr/NX/etc/node.cfg /usr/NX/etc/server.cfg

    If key unix-xsession-default is not present, add it in the AvailableSessionTypes and then execute:
    sudo /etc/NX/nxserver --configupdate

    As well you could execute on ETS sudo /etc/NX/nxserver --resourcelist --class session --node nnn.nnn.nnn.nnn:4000 to check if the session type is enabled.

    If that does not help, can you share your server.cfg and node.cfg files from ETS and ETSN.You can attach them here or send to forum[at]nomachine[dot]com, by referencing this topic.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.