SL 6.5 cannot locate X server

Forum / NoMachine for Linux / SL 6.5 cannot locate X server

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #11182

    Since the latest Linux RPM is borked I’m using

    /etc/NX/nxserver –version

    NoMachine – Version 5.1.9

    We are using the latest Windows client to connect. The NX server cannot locate the running X display :0 but it is there

    root      9091  0.6  1.4 354936 230548 tty7    Ss+  Apr12 212:42 /usr/bin/X :0



    We were not able to reproduce this problem on SL 6.5. Could you enable logs in server and node configuration file, reproduce the problem and then send to us whole /usr/NX/var/log directory to
    forum[at]nomachine[dot]com or attach them here (size is restricted).

    Instructions about debug and collecting logs you can find there:


    Emailed logs, let me know if you need something else. Noticed newer versions this morning and used them. Trying Enterprise evals of client and server


    It seems that nxserver found Xorg but the problem is with reaching cookie of it.
    In particular system xauth reports warning and exits with code 1:
    /usr/bin/xauth: /home/users/weigand/.serverauth.9074 not writable, changes will be ignored

    Its very likely a problem with wrong SELinux context to this .serverauth.9074 file.

    To verify current context you can use command:

    ls -Z /home/users/weigand/.serverauth.9074

    To set correct context you can use this command:

    chcon -Rv unconfined_u:object_r:xauth_home_t:s0 /home/users/weigand/.serverauth.9074


    We have selinux disabled and the home area is on NFS.

    Current .serverauth file /usr/bin/X :0 -auth /home/users/weigand/.serverauth.28946

    chcon -Rv unconfined_u:object_r:xauth_home_t:s0 /home/users/weigand/.serverauth.28946

    Changing security context of `/home/users/weigand/.serverauth.28946′

    chcon: failed to change context of /home/users/weigand/.serverauth.28946′ tounconfined_u:object_r:xauth_home_t:s0′: Operation not permitted

    I have also tried to set the server to allow SSH connections and I’m getting that the server does not allow it even though I’ve updated the server.cfg and node.cfg


    ClientConnectionMethods NX,SSH


    You are using NoMachine product which support only NX connection methods (it doesn’t support SSH).

    About access to the .serverauth, NFS prevent to access file as root which seems to be a reason
    of that issue. Please verify ownership of the .serverauth file, and configuration of NFS.

    Likely option no_root_squash in NFS configuration is needed, for allow to local root account
    access a filesystem exported by NFS. Note that this is insecure which is a reason that in default
    configuration NFS has it disabled.


    Update. I noticed the ipv6 errors in the nxerror.log file (we disable IPv6 on our hosts). So I wanted to clear that error from the mix. Now that IPv6 is enabled NX works like a champ.

    We use the Centos wiki recommended method to disable it so there is something tied to IPv6 that is borked.



    This is all with NX protocol, still can’t get SSH working

    nouveau ipv6 enabled desktop:0 appears instantly

    nouveau ipv6 disabled desktop:0 unavailable decline creating new desktop, wait a minute and desktop:0 is available

    nvidia ipv6 disabled desktop:0 unavailable decline creating new desktop desktop:0 never available

    nvidia ipv6 enabled desktop:0 unavailable decline creating new desktop, wait a minute and desktop:0 is available


    Please check Brotech’s reply just above.


    I’m not gonna set that to make this new version work. I’d like it to work just like the older versions we have used. Our environment has not changed wrt home areas on NFS nor have the mount options changed.

    -rw——- 1 UID GID 64 May 26 15:11 .serverauth.28946


    Please also see that this is somehow related to ipV6 as my 5/25 post supplied more information. so obviously the NFS area is not the issue.


    so far we were not able reproduced problem using Scientific Linux 6 in its default installation with desktop, regardless whether ipv6 is enabled or disabled.

    Could you provide more info about what SL you’ve installed exactly, or if you’ve customize it in any way? For example the output of rpm -qa (all installed packages) could help us replicate the same environment. Are you using any Display Manager or just starting desktop using startx command ?

    Then please consider re-enabling debug, restart nxserver and send to us logs again after display 0 became available. The logs you sent to us before don’t contain debug of daemon server which is searching and reporting local X server.

    Please look for the current working authority file of Xserver using command: ps -ef | grep X
    Among parameters of that process should also be -auth userhome/

    Use path to that file in following command, executed from command like:
    xauth -f userhome/ list

    It should report all cookies set and in use by current Xserver, and it is likely we can see the cause of the problem from that.

    Please attach also output from /sbin/ifconfig command, and content of /etc/hosts.

Viewing 11 posts - 1 through 11 (of 11 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.